summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Van Gestel2021-08-24 23:15:24 +0200
committerMatthias Van Gestel2021-08-24 23:15:24 +0200
commit413a1b1252dde57d51748415b770ede2af436d6e (patch)
treed4dce7b8033595c2c57b1068632121ccc11ce4ff
parent86c5b133af477438b011129b1256a37a725f8529 (diff)
downloadaur-413a1b1252dde57d51748415b770ede2af436d6e.tar.gz
Correcting the PKGBUILD (thanks Fabio)
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD10
2 files changed, 17 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c96bce415eb8..ee45d274e0b5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,18 @@
pkgbase = amxb-inspect-git
pkgdesc = Ambiorix Backend inspector/validation tool
- pkgver = v1.0.6.r0.g048460d
+ pkgver = 1.0.6.r0.g048460d
pkgrel = 1
url = https://gitlab.com/soft.at.home/ambiorix/applications/amxb-inspect.git
- arch = any
- license = MIT
+ arch = x86_64
+ arch = i686
+ arch = i486
+ arch = pentium4
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = BSD
+ makedepends = git
depends = lib_amxb
provides = amxb-inspect
conflicts = amxb-inspect
diff --git a/PKGBUILD b/PKGBUILD
index 140e5abf08ea..e15307c11125 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
# Maintainer: fenrig <fenrig.linux at outlook.com>
pkgname=amxb-inspect-git
-pkgver=v1.0.6.r0.g048460d
+pkgver=1.0.6.r0.g048460d
pkgrel=1
pkgdesc="Ambiorix Backend inspector/validation tool"
-arch=('any')
+arch=("x86_64" "i686" "i486" "pentium4" "arm" "armv6h" "armv7h" "aarch64")
url="https://gitlab.com/soft.at.home/ambiorix/applications/amxb-inspect.git"
-license=('MIT')
+license=(BSD)
depends=(
'lib_amxb'
)
makedepends=(
+ 'git'
)
provides=(
'amxb-inspect'
@@ -26,7 +27,7 @@ md5sums=('SKIP')
pkgver() {
cd "${pkgname}"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
@@ -37,4 +38,5 @@ build() {
package() {
cd "${pkgname}"
make DEST="${pkgdir}/" LIBDIR="/usr/lib" install
+ install -D LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}