summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Van Gestel2021-08-24 23:19:04 +0200
committerMatthias Van Gestel2021-08-24 23:19:04 +0200
commit7e5ffdb630072369107bde440bdd380855bd7f70 (patch)
tree62094f1edc5bdff5613f86a0702879780bee767c
parent062a3a05c8882988d57b53ac5ff730767ce8b64c (diff)
downloadaur-7e5ffdb630072369107bde440bdd380855bd7f70.tar.gz
Correcting the PKGBUILD (thanks Fabio)
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD10
2 files changed, 17 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cae9b4a6d9d4..842bd6aca27c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,18 @@
pkgbase = amxb_ubus-git
pkgdesc = Ubus baapi back-end
- pkgver = v2.1.4.r0.g15647f6
+ pkgver = 2.1.5.r0.gff976c6
pkgrel = 1
url = https://gitlab.com/soft.at.home/ambiorix/modules/amxb_backends/amxb_ubus.git
- arch = any
- license = MIT
+ arch = x86_64
+ arch = i686
+ arch = i486
+ arch = pentium4
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = BSD
+ makedepends = git
depends = lib_amxc
depends = lib_amxp
depends = libubox
diff --git a/PKGBUILD b/PKGBUILD
index 9e7d5cc19f51..1e57b3b9683b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: fenrig <fenrig.linux at outlook.com>
pkgname=amxb_ubus-git
-pkgver=v2.1.4.r0.g15647f6
+pkgver=2.1.5.r0.gff976c6
pkgrel=1
pkgdesc="Ubus baapi back-end"
-arch=('any')
+arch=("x86_64" "i686" "i486" "pentium4" "arm" "armv6h" "armv7h" "aarch64")
url="https://gitlab.com/soft.at.home/ambiorix/modules/amxb_backends/amxb_ubus.git"
-license=('MIT')
+license=(BSD)
depends=(
'lib_amxc'
@@ -14,6 +14,7 @@ depends=(
'ubus'
)
makedepends=(
+ 'git'
)
provides=(
'amxb_ubus'
@@ -29,7 +30,7 @@ md5sums=('SKIP')
pkgver() {
cd "${pkgname}"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
@@ -40,4 +41,5 @@ build() {
package() {
cd "${pkgname}"
make DEST="${pkgdir}/" LIBDIR="/usr/lib" install
+ install -D LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}