summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Van Gestel2020-11-05 21:27:36 +0100
committerMatthias Van Gestel2020-11-05 21:27:36 +0100
commitf086ade242a4f10c4c435f7e2965b1cdbc796254 (patch)
tree08cefc7a048a1d6b93fd0be253a661498aedd967
downloadaur-f086ade242a4f10c4c435f7e2965b1cdbc796254.tar.gz
Initial drop of amxb_bus
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD43
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..30070689f47d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = amxb_ubus-git
+ pkgdesc = Ubus baapi back-end
+ pkgver = v0.3.3.r0.gca31123
+ pkgrel = 1
+ url = https://gitlab.com/soft.at.home/ambiorix/modules/amxb_backends/amxb_ubus.git
+ arch = any
+ license = MIT
+ depends = lib_amxc
+ depends = lib_amxp
+ depends = libubox
+ depends = libubus
+ provides = amxb_ubus
+ conflicts = amxb_ubus
+ source = amxb_ubus-git::git+https://gitlab.com/soft.at.home/ambiorix/modules/amxb_backends/amxb_ubus.git#branch=master
+ md5sums = SKIP
+
+pkgname = amxb_ubus-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f278d239b341
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: fenrig <fenrig.linux at outlook.com>
+pkgname=amxb_ubus-git
+pkgver=v0.3.3.r0.gca31123
+pkgrel=1
+pkgdesc="Ubus baapi back-end"
+arch=('any')
+url="https://gitlab.com/soft.at.home/ambiorix/modules/amxb_backends/amxb_ubus.git"
+license=('MIT')
+
+depends=(
+ 'lib_amxc'
+ 'lib_amxp'
+ 'libubox'
+ 'libubus'
+)
+makedepends=(
+)
+provides=(
+ 'amxb_ubus'
+)
+conflicts=(
+ 'amxb_ubus'
+)
+
+gitbranch="master"
+
+source=("${pkgname}::git+https://gitlab.com/soft.at.home/ambiorix/modules/amxb_backends/amxb_ubus.git#branch=${gitbranch}")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${pkgname}"
+ make
+}
+
+package() {
+ cd "${pkgname}"
+ make DEST="${pkgdir}/" INSTALL_LIB_DIR="/lib" install
+}