summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfenriglinux2020-11-04 22:18:32 +0100
committerfenriglinux2020-11-04 22:18:32 +0100
commitab9ffd28014c4a3a4053ea18372faf48420a7e95 (patch)
tree857cd7420f77372d09e281910a1cb3252a707705
downloadaur-ab9ffd28014c4a3a4053ea18372faf48420a7e95.tar.gz
Initial drop of amxo-cg
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD42
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..09d9e85b30ed
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = amxo-cg-git
+ pkgdesc = ODL (Object Definition Language) Compiler/Generator
+ pkgver = v0.2.0.r0.ga65db64
+ pkgrel = 1
+ url = https://gitlab.com/soft.at.home/ambiorix/applications/amxo-cg.git
+ arch = any
+ license = MIT
+ depends = lib_amxc
+ depends = lib_amxd
+ depends = lib_amxo
+ provides = amxo-cg
+ conflicts = amxo-cg
+ source = amxo-cg-git::git+https://gitlab.com/soft.at.home/ambiorix/applications/amxo-cg.git#branch=master
+ md5sums = SKIP
+
+pkgname = amxo-cg-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6d963a8c6b82
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: fenrig <fenrig.linux at outlook.com>
+pkgname=amxo-cg-git
+pkgver=v0.2.0.r0.ga65db64
+pkgrel=1
+pkgdesc="ODL (Object Definition Language) Compiler/Generator"
+arch=('any')
+url="https://gitlab.com/soft.at.home/ambiorix/applications/amxo-cg.git"
+license=('MIT')
+
+depends=(
+ 'lib_amxc'
+ 'lib_amxd'
+ 'lib_amxo'
+)
+makedepends=(
+)
+provides=(
+ 'amxo-cg'
+)
+conflicts=(
+ 'amxo-cg'
+)
+
+gitbranch="master"
+
+source=("${pkgname}::git+https://gitlab.com/soft.at.home/ambiorix/applications/amxo-cg.git#branch=${gitbranch}")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${pkgname}"
+ make
+}
+
+package() {
+ cd "${pkgname}"
+ make DEST="${pkgdir}/" install
+}