summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMar0xy2021-12-11 03:14:43 +0100
committerMar0xy2021-12-11 03:14:43 +0100
commit6ff4eb44693e05ee903a6b07eb46f5b06a7d8876 (patch)
treefa825a95bc5c2c627bbe73719f0222a539cf95a2
downloadaur-6ff4eb44693e05ee903a6b07eb46f5b06a7d8876.tar.gz
Push to AUR
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD51
-rw-r--r--an-anime-game-launcher-bin.desktop8
-rw-r--r--an-anime-game-launcher-bin.sh3
-rw-r--r--icon.pngbin0 -> 77748 bytes
5 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0e887d79821f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = an-anime-game-launcher-bin
+ pkgdesc = An Launcher for a specific anime game written in Electron with auto-patching and playtime tracking function
+ pkgver = 1.8.0
+ pkgrel = 1
+ url = https://gitlab.com/KRypt0n_/an-anime-game-launcher
+ arch = x86_64
+ license = GPL3
+ depends = electron
+ depends = tar
+ depends = unzip
+ depends = xdelta3
+ depends = cabextract
+ depends = git
+ optdepends = mangohud: FPS Hud/GUI
+ optdepends = gamemode: Game Optimizations
+ optdepends = switcheroo-control: Hybrid GPU Support
+ optdepends = vkbasalt: Required to use custom shaders (install this and reshade-shaders-git)
+ optdepends = reshade-shaders-git: Required by vkBasalt config files (install this and vkbasalt)
+ replaces = an-anime-game-launcher
+ source = an-anime-game-aur-1.8.0.tar.gz::https://dev.kaifa.ch/Maroxy/an-anime-game-aur/archive/1.8.0.tar.gz
+ source = icon.png
+ source = an-anime-game-launcher-bin.desktop
+ source = an-anime-game-launcher-bin.sh
+ md5sums = a1feac9dda692232dfddb16a9e13111c
+ md5sums = 82d75ad72aed6c6962f203f9c6f329d3
+ md5sums = 7022b1fe2765112dae39285a286bcedb
+ md5sums = 1fd9f85ce430fd7a49df0cdf212b7516
+
+pkgname = an-anime-game-launcher-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..54630aa9ff83
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+ # Maintainer: Marie Piontek <marie@kaifa.ch>
+
+pkgname=an-anime-game-launcher-bin
+pkgver=1.8.0
+pkgrel=1
+pkgdesc="An Launcher for a specific anime game written in Electron with auto-patching and playtime tracking function"
+url="https://gitlab.com/KRypt0n_/an-anime-game-launcher"
+replaces=("an-anime-game-launcher")
+arch=("x86_64")
+license=("GPL3")
+
+depends=(
+ "electron"
+ "tar"
+ "unzip"
+ "xdelta3"
+ "cabextract"
+ "git"
+)
+
+optdepends=(
+ "mangohud: FPS Hud/GUI"
+ "gamemode: Game Optimizations"
+ "switcheroo-control: Hybrid GPU Support"
+ "vkbasalt: Required to use custom shaders (install this and reshade-shaders-git)"
+ "reshade-shaders-git: Required by vkBasalt config files (install this and vkbasalt)"
+)
+
+source=(
+ "an-anime-game-aur-${pkgver}.tar.gz::https://dev.kaifa.ch/Maroxy/an-anime-game-aur/archive/${pkgver}.tar.gz"
+ "icon.png"
+ "an-anime-game-launcher-bin.desktop"
+ "an-anime-game-launcher-bin.sh"
+)
+
+md5sums=(
+ 'a1feac9dda692232dfddb16a9e13111c'
+ '82d75ad72aed6c6962f203f9c6f329d3'
+ '7022b1fe2765112dae39285a286bcedb'
+ '1fd9f85ce430fd7a49df0cdf212b7516'
+)
+
+package() {
+ cd "an-anime-game-aur"
+ install -dm755 "${pkgdir}/usr/lib/${pkgname}"
+ cp -dr --no-preserve=ownership app.asar "${pkgdir}/usr/lib/${pkgname}/"
+
+ install -Dm644 "${srcdir}/icon.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ install -Dm755 "${srcdir}/an-anime-game-launcher-bin.sh" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 "${srcdir}/an-anime-game-launcher-bin.desktop" -t "${pkgdir}/usr/share/applications"
+}
diff --git a/an-anime-game-launcher-bin.desktop b/an-anime-game-launcher-bin.desktop
new file mode 100644
index 000000000000..0d22034dba10
--- /dev/null
+++ b/an-anime-game-launcher-bin.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=An Anime Game Launcher
+Comment=An Anime Game launcher for Linux written on Electron with automatic anti-cheat patching and telemetry disabling
+Exec=an-anime-game-launcher-bin
+Terminal=false
+Type=Application
+Icon=an-anime-game-launcher-bin
+Categories=Game
diff --git a/an-anime-game-launcher-bin.sh b/an-anime-game-launcher-bin.sh
new file mode 100644
index 000000000000..65de76abfe22
--- /dev/null
+++ b/an-anime-game-launcher-bin.sh
@@ -0,0 +1,3 @@
+#!/bin/bash
+
+exec electron /usr/lib/an-anime-game-launcher-bin/app.asar "$@"
diff --git a/icon.png b/icon.png
new file mode 100644
index 000000000000..89738cd2787e
--- /dev/null
+++ b/icon.png
Binary files differ