summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxstraok2023-03-04 15:03:57 -0500
committerxstraok2023-03-04 15:03:57 -0500
commit87e6d6083db18af737ccddfd8479f9869e1c1777 (patch)
tree5beeb6051fe71386305c82da64002a4a13848cf2
parentdc2cad03ac984db919763645b35f7ad71f258c5d (diff)
downloadaur-87e6d6083db18af737ccddfd8479f9869e1c1777.tar.gz
3.0.1
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD44
-rw-r--r--an-anime-game-launcher.desktop8
-rw-r--r--icon.pngbin77748 -> 76665 bytes
4 files changed, 41 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e7801ccd2639..5d9def0365c7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = an-anime-game-launcher-bin
- pkgdesc = An Launcher for a specific anime game with auto-patching, discord rpc and time tracking
- pkgver = 2.4.5
+ pkgdesc = A Launcher for a specific anime game with auto-patching, discord rpc and time tracking
+ pkgver = 3.0.1
pkgrel = 1
url = https://github.com/an-anime-team/an-anime-game-launcher
arch = x86_64
license = GPL3
- depends = libayatana-appindicator
+ depends = libadwaita
depends = tar
depends = unzip
depends = xdelta3
@@ -13,19 +13,18 @@ pkgbase = an-anime-game-launcher-bin
depends = git
depends = curl
depends = iputils
- depends = webkit2gtk
+ depends = gtk4
+ depends = glibc
optdepends = mangohud: FPS Hud/GUI
optdepends = gamemode: Game Optimizations
- optdepends = vkbasalt: Required to use custom shaders (install this and reshade-shaders-git)
- optdepends = reshade-shaders-git: Required by vkBasalt config files (install this and vkbasalt)
+ optdepends = gamescope: a tool from Valve that allows for games to run in an isolated Xwayland instance
+ provides = an-anime-game-launcher
conflicts = an-anime-game-launcher
- source = An_Anime_Game_Launcher_2.4.5.AppImage::https://github.com/an-anime-team/an-anime-game-launcher/releases/download/2.4.5/an-anime-game-launcher-2.4.5.AppImage
+ source = an-anime-game-launcher_3.0.1::https://github.com/an-anime-team/an-anime-game-launcher/releases/download/3.0.1/anime-game-launcher
source = icon.png
- source = an-anime-game-launcher-bin.desktop
- source = an-anime-game-launcher-bin.sh
- md5sums = 8882484d250db56d3e0fb6e770932ce1
- md5sums = 82d75ad72aed6c6962f203f9c6f329d3
- md5sums = acb9fecb5d938c4fb8e5facb0511bc23
- md5sums = aa1d36e938b47b1f9fcff6aa5cec588b
+ source = an-anime-game-launcher.desktop
+ md5sums = a4bdfef0e10aa5fdb7c9f04593376697
+ md5sums = c1a5499b80a55d3d238ef5c5d2c93c99
+ md5sums = 12d89b3be2072437e7b252af97274142
pkgname = an-anime-game-launcher-bin
diff --git a/PKGBUILD b/PKGBUILD
index b911975bfdc3..fbb0022295fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,18 @@
-# Maintainer: Marie Piontek <marie@kaifa.ch>
+# Maintainer: Maxim Korotkov <maximkorotkov4@gmail.com>
+# Contributor: Marie Piontek <marie@kaifa.ch>
pkgname=an-anime-game-launcher-bin
-pkgver=2.4.5
+pkgver=3.0.1
pkgrel=1
-pkgdesc="An Launcher for a specific anime game with auto-patching, discord rpc and time tracking"
+pkgdesc="A Launcher for a specific anime game with auto-patching, discord rpc and time tracking"
url="https://github.com/an-anime-team/an-anime-game-launcher"
conflicts=("an-anime-game-launcher")
+provides=("an-anime-game-launcher")
arch=("x86_64")
license=("GPL3")
depends=(
- "libayatana-appindicator"
+ "libadwaita"
"tar"
"unzip"
"xdelta3"
@@ -18,43 +20,39 @@ depends=(
"git"
"curl"
"iputils"
- "webkit2gtk"
+ "gtk4"
+ "glibc"
)
optdepends=(
"mangohud: FPS Hud/GUI"
"gamemode: Game Optimizations"
- "vkbasalt: Required to use custom shaders (install this and reshade-shaders-git)"
- "reshade-shaders-git: Required by vkBasalt config files (install this and vkbasalt)"
+ "gamescope: a tool from Valve that allows for games to run in an isolated Xwayland instance"
)
source=(
- "An_Anime_Game_Launcher_${pkgver}.AppImage::https://github.com/an-anime-team/an-anime-game-launcher/releases/download/${pkgver}/an-anime-game-launcher-${pkgver}.AppImage"
+ "an-anime-game-launcher_${pkgver}::https://github.com/an-anime-team/an-anime-game-launcher/releases/download/${pkgver}/anime-game-launcher"
"icon.png"
- "an-anime-game-launcher-bin.desktop"
- "an-anime-game-launcher-bin.sh"
+ "an-anime-game-launcher.desktop"
)
md5sums=(
- '8882484d250db56d3e0fb6e770932ce1'
- '82d75ad72aed6c6962f203f9c6f329d3'
- 'acb9fecb5d938c4fb8e5facb0511bc23'
- 'aa1d36e938b47b1f9fcff6aa5cec588b'
+ 'a4bdfef0e10aa5fdb7c9f04593376697'
+ 'c1a5499b80a55d3d238ef5c5d2c93c99'
+ '12d89b3be2072437e7b252af97274142'
)
prepare() {
- chmod +x "${srcdir}/An_Anime_Game_Launcher_${pkgver}.AppImage"
- "${srcdir}/An_Anime_Game_Launcher_${pkgver}.AppImage" --appimage-extract
+ chmod +x "${srcdir}/an-anime-game-launcher_${pkgver}"
}
package() {
- cd "squashfs-root"
install -dm755 "${pkgdir}/usr/lib/${pkgname}"
- cp -dr --no-preserve=ownership resources.neu "${pkgdir}/usr/lib/${pkgname}/"
- cp -dr --no-preserve=ownership an-anime-game-launcher "${pkgdir}/usr/lib/${pkgname}/"
- cp -dr --no-preserve=ownership public "${pkgdir}/usr/lib/${pkgname}/"
+ install -dm755 "${pkgdir}/usr/bin/"
+ cp an-anime-game-launcher_${pkgver} "${pkgdir}/usr/lib/${pkgname}/"
- install -Dm644 "${srcdir}/icon.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
- install -Dm755 "${srcdir}/an-anime-game-launcher-bin.sh" "${pkgdir}/usr/bin/${pkgname}"
- install -Dm644 "${srcdir}/an-anime-game-launcher-bin.desktop" -t "${pkgdir}/usr/share/applications"
+ install -Dm644 "${srcdir}/icon.png" "${pkgdir}/usr/share/pixmaps/an-anime-game-launcher.png"
+ ln -s "/usr/lib/${pkgname}/an-anime-game-launcher_${pkgver}" "${pkgdir}/usr/bin/an-anime-game-launcher"
+ install -Dm644 "${srcdir}/an-anime-game-launcher.desktop" -t "${pkgdir}/usr/share/applications"
}
+
diff --git a/an-anime-game-launcher.desktop b/an-anime-game-launcher.desktop
new file mode 100644
index 000000000000..2cf3afb79677
--- /dev/null
+++ b/an-anime-game-launcher.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=An Anime Game Launcher
+Comment=An Launcher for a specific anime game with auto-patching, discord rpc and time tracking
+Exec=an-anime-game-launcher
+Terminal=false
+Type=Application
+Icon=an-anime-game-launcher
+Categories=Game
diff --git a/icon.png b/icon.png
index 89738cd2787e..3beaa2b46b73 100644
--- a/icon.png
+++ b/icon.png
Binary files differ