summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfnrir2023-07-20 14:35:53 +0200
committerfnrir2023-07-20 14:35:53 +0200
commit568e2371e3984f4efb2e73c86dd79ae1515ae7e2 (patch)
tree6ad92630fd27f2a409b84062172ef567e74e44ad
parent33d519f4df3fd5c096d24fda15928989e8f80fd8 (diff)
downloadaur-568e2371e3984f4efb2e73c86dd79ae1515ae7e2.tar.gz
Update PKGBUILD and patch
-rw-r--r--PKGBUILD8
-rw-r--r--discord-no-panic.patch8
2 files changed, 6 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 64068e856cda..9a8038d23cb2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributer: DrakeTDL <everyone@disroot.org>
_pkgname="an-anime-game-launcher"
pkgname="$_pkgname-patched-git"
-pkgver=3.7.0.r0.g7bae189
+pkgver=3.7.6.r0.g1479edf
pkgrel=1
pkgdesc="A Launcher for a specific anime game with auto-patching, discord rpc and time tracking (with a couple of fixes)"
arch=("x86_64")
@@ -31,7 +31,6 @@ source=(
"git+https://github.com/an-anime-team/an-anime-game-launcher"
"git+https://github.com/an-anime-team/anime-launcher-sdk"
"${_pkgname}.desktop"
- "use-cloned-sdk.patch"
"discord-no-panic.patch"
)
noextract=()
@@ -39,8 +38,7 @@ sha256sums=(
SKIP
SKIP
"3bb15b29fd47e60ead712a67046daf42bd0ba5547d379ead6ea9bba37ea7b137"
- "41bf614e86d2b439dde5dd60ea2e1384f420656d24cc5f075e2b4e9d0fb2b31d"
- "207069d6510fbfa09a157f942da48c2985cb05780aa44c00f1ba9909201dacb1"
+ "b05d3724d2c12609650f0229b9bebc743399b96f1f739a50c63cbc0689810ea9"
)
pkgver() {
@@ -52,9 +50,7 @@ prepare() {
cd "${_pkgname}"
git submodule update --init --recursive --single-branch
- #sdkver=$(grep -Pazo '(?s)\[dependencies\.anime-launcher-sdk\]\ngit = "\S+"\ntag = "\S+"' Cargo.toml | tail -n 1 | cut -d '"' -f 2)
# Use cloned anime-launcher-sdk
- #patch -up1 -i "../use-cloned-sdk.patch"
code='import toml
with open("Cargo.toml", "rt") as file:
cargo = toml.load(file)
diff --git a/discord-no-panic.patch b/discord-no-panic.patch
index cd80a93b4cfa..7b6083a9698c 100644
--- a/discord-no-panic.patch
+++ b/discord-no-panic.patch
@@ -1,8 +1,8 @@
diff --git a/src/discord_rpc.rs b/src/discord_rpc.rs
-index 0d7416c..8880760 100644
+index fe134c0..0119988 100644
--- a/src/discord_rpc.rs
+++ b/src/discord_rpc.rs
-@@ -52,15 +52,22 @@ impl DiscordRpc {
+@@ -71,15 +71,22 @@ impl DiscordRpc {
let mut connected = false;
while let Ok(update) = receiver.recv() {
@@ -31,7 +31,7 @@ index 0d7416c..8880760 100644
}
}
-@@ -68,7 +75,9 @@ impl DiscordRpc {
+@@ -87,7 +94,9 @@ impl DiscordRpc {
if connected {
connected = false;
@@ -42,7 +42,7 @@ index 0d7416c..8880760 100644
}
}
-@@ -79,13 +88,17 @@ impl DiscordRpc {
+@@ -98,13 +107,17 @@ impl DiscordRpc {
if connected {
client.set_activity(Self::get_activity(&params))