summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafael Reggiani Manzo2015-10-10 10:33:57 -0300
committerRafael Reggiani Manzo2015-10-10 10:33:57 -0300
commit8b3a392cb49033268312a043d0ed5ba7757d681e (patch)
tree9da24883e42a3023a95660048d4f5fe075a10bdc
parentef612395c3a608be33e22bf0de5c78b13675a613 (diff)
downloadaur-8b3a392cb49033268312a043d0ed5ba7757d681e.tar.gz
More packaged perl dependencies used
There is a issue with pacaur that does not handle AUR dependencies listed on checkdepend. When this gets fixed one dependency may get dropped. The missing dependencies now must be packaged.
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8ad5f73b12ec..fa3ff68ecd11 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = analizo
pkgdesc = Analizo is a free, multi-language, extensible source code analysis and visualization toolkit.
pkgver = 1.18.1
- pkgrel = 4
+ pkgrel = 5
url = http://analizo.org
arch = any
groups = analizo
@@ -11,9 +11,12 @@ pkgbase = analizo
depends = perl-cpanplus-dist-arch
depends = sloccount
depends = doxyparse
+ depends = perl-chi
+ depends = perl-test-without-module
depends = perl-app-cmd
depends = perl-class
depends = perl-data-uuid
+ depends = perl-digest-jhash
depends = perl-list-moreutils
depends = perl-file-homedir
depends = perl-file-copy-recursive
diff --git a/PKGBUILD b/PKGBUILD
index ed2f97e0e541..518d62079a28 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,15 @@
pkgname=analizo
pkgver=1.18.1
-pkgrel=4
+pkgrel=5
pkgdesc="Analizo is a free, multi-language, extensible source code analysis and visualization toolkit."
groups=('analizo')
arch=('any')
url="http://analizo.org"
license=('GPLv3')
depends=('perl' 'perl-cpanplus-dist-arch' 'sloccount' 'doxyparse'
- 'perl-app-cmd' 'perl-class' 'perl-data-uuid'
+ 'perl-chi' 'perl-test-without-module' # perl-test-without-module is only necessary as long as this issue does not gets fixed: https://github.com/rmarquis/pacaur/issues/367
+ 'perl-app-cmd' 'perl-class' 'perl-data-uuid' 'perl-digest-jhash'
'perl-list-moreutils' 'perl-file-homedir'
'perl-file-copy-recursive' 'perl-getopt-euclid' 'perl-graph'
'perl-list-compare' 'perl-mro-compat' 'perl-file-sharedir-install'
@@ -23,12 +24,10 @@ build(){
cd "${srcdir}/${pkgname}"
#Perl modules
- cpanp -i --skiptest CHI # This package has dependencies that have not been migrated yet to AUR 4: perl-moox-types-mooselike-numeric, perl-exporter-lite (through perl-time-duration-parse)
- cpanp -i --skiptest Digest::JHash # The package source url is broken
cpanp -i --skiptest Statistics::Descriptive # Left behind on AUR 3 to 4 migration
cpanp -i --skiptest Statistics::OnLine # Looks like there is no Oficial or AUR candidate
cpanp -i --skiptest FindBin::libs # Looks like there is no Oficial or AUR candidate
- cpanp -i --skiptest Graph::Writer::DSM # Looks like there is no Oficial or AUR candidate (it may be provided by perl-graph)
+ cpanp -i --skiptest Graph::Writer::DSM # Looks like there is no Oficial or AUR candidate
#Analizo
perl Makefile.PL