summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafael Reggiani Manzo2015-09-30 18:54:32 -0300
committerRafael Reggiani Manzo2015-09-30 18:54:32 -0300
commitba90ddc48c73bd1b7e55dcce4db1179e4c85c74c (patch)
tree5888dc99af8059fba8aff6fc537bf0950253dd56
parentd2aa02980c5950f64cd02616e35d767bf76fd7c5 (diff)
downloadaur-ba90ddc48c73bd1b7e55dcce4db1179e4c85c74c.tar.gz
Remove broken dependencies
On the move from AUR 4 to 3, some packages got missing dependencies or were lost themselves.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD9
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e41d952a9f5a..f80b1084aaef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = analizo
pkgdesc = Analizo is a free, multi-language, extensible source code analysis and visualization toolkit.
pkgver = 1.18.1
- pkgrel = 2
+ pkgrel = 3
url = http://analizo.org
arch = any
groups = analizo
@@ -12,7 +12,6 @@ pkgbase = analizo
depends = sloccount
depends = doxyparse
depends = perl-app-cmd
- depends = perl-chi
depends = perl-class
depends = perl-data-uuid
depends = perl-digest-jhash
diff --git a/PKGBUILD b/PKGBUILD
index e15dbccf776a..3a7d1c64246b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
pkgname=analizo
pkgver=1.18.1
-pkgrel=2
+pkgrel=3
pkgdesc="Analizo is a free, multi-language, extensible source code analysis and visualization toolkit."
groups=('analizo')
arch=('any')
url="http://analizo.org"
license=('GPLv3')
depends=('perl' 'perl-cpanplus-dist-arch' 'sloccount' 'doxyparse'
- 'perl-app-cmd' 'perl-chi' 'perl-class' 'perl-data-uuid'
+ 'perl-app-cmd' 'perl-class' 'perl-data-uuid'
'perl-digest-jhash' 'perl-list-moreutils' 'perl-file-homedir'
'perl-file-copy-recursive' 'perl-getopt-euclid' 'perl-graph'
'perl-list-compare' 'perl-mro-compat' 'perl-file-sharedir-install'
@@ -23,10 +23,11 @@ build(){
cd "${srcdir}/${pkgname}"
#Perl modules
- cpanp -i --skiptest Statistics::Descriptive # Looks like there is no Oficial or AUR candidate
+ cpanp -i --skiptest CHI # This package has dependencies that have not been migrated yet to AUR 4: perl-moox-types-mooselike-numeric, perl-exporter-lite (through perl-time-duration-parse)
+ cpanp -i --skiptest Statistics::Descriptive # Left behind on AUR 3 to 4 migration
cpanp -i --skiptest Statistics::OnLine # Looks like there is no Oficial or AUR candidate
cpanp -i --skiptest FindBin::libs # Looks like there is no Oficial or AUR candidate
- cpanp -i --skiptest Graph::Writer::DSM # Looks like there is no Oficial or AUR candidate
+ cpanp -i --skiptest Graph::Writer::DSM # Looks like there is no Oficial or AUR candidate (it may be provided by perl-graph)
#Analizo
perl Makefile.PL