summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntoine Viallon2022-01-14 15:18:03 +0100
committerAntoine Viallon2022-01-14 15:18:36 +0100
commitcb5ed8638469e1fe070d4918163cd1604077e459 (patch)
tree308f38d23ce1082f2d5f77fc2b3e882c87418398
parent44677c949bca9c25b4c16bde0a7adcd6b3f3f4d5 (diff)
downloadaur-cb5ed8638469e1fe070d4918163cd1604077e459.tar.gz
Update to 1.0.0-rc6 and fix systemd service not being exported
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD29
2 files changed, 28 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4dde7404c440..8c9251540335 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = ananicy-cpp
pkgdesc = Ananicy Cpp is a full rewrite of Ananicy in C++, featuring lower CPU and RAM usage.
- pkgver = 1.0.0.rc5
- pkgrel = 2
+ pkgver = 1.0.0.rc6
+ pkgrel = 1
url = https://gitlab.com/ananicy-cpp/ananicy-cpp/
arch = x86_64
arch = i386
arch = armv7h
+ arch = x86_64_v3
license = GPLv3
makedepends = cmake
makedepends = git
@@ -14,7 +15,9 @@ pkgbase = ananicy-cpp
depends = nlohmann-json
depends = systemd
optdepends = ananicy-rules-git: community rules
- source = https://gitlab.com/ananicy-cpp/ananicy-cpp/-/archive/v1.0.0-rc5/ananicy-cpp-v1.0.0-rc5.tar.gz
- md5sums = 6d8caf9cb384e053df54d795102beb1d
+ source = https://gitlab.com/ananicy-cpp/ananicy-cpp/-/archive/v1.0.0-rc6/ananicy-cpp-v1.0.0-rc6.tar.gz
+ source = https://gitlab.com/ananicy-cpp/stl-polyfills/std-format/-/archive/45296602ad78a804411e7c3b617e13759f38e4e7/std-format-45296602ad78a804411e7c3b617e13759f38e4e7.tar.gz
+ md5sums = 237f06e257092b5a13833b2364f95633
+ md5sums = SKIP
pkgname = ananicy-cpp
diff --git a/PKGBUILD b/PKGBUILD
index 65782717ab69..726080bcddc0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,27 @@
# Maintainer: Antoine Viallon <antoine@lesviallon.fr>
pkgname=ananicy-cpp
-_pkgver=1.0.0-rc5
+_pkgver=1.0.0-rc6
pkgver=${_pkgver//-/.}
-pkgrel=2
+pkgrel=1
pkgdesc="Ananicy Cpp is a full rewrite of Ananicy in C++, featuring lower CPU and RAM usage."
url="https://gitlab.com/ananicy-cpp/ananicy-cpp/"
license=(GPLv3)
source=(
"https://gitlab.com/ananicy-cpp/${pkgname}/-/archive/v${_pkgver}/${pkgname}-v${_pkgver}.tar.gz"
)
-md5sums=('6d8caf9cb384e053df54d795102beb1d')
-arch=(x86_64 i386 armv7h)
+md5sums=('237f06e257092b5a13833b2364f95633')
+
+
+declare -g -A externals
+externals['std-format']="45296602ad78a804411e7c3b617e13759f38e4e7"
+
+for external in "${!externals[@]}"; do
+ source+=(https://gitlab.com/ananicy-cpp/stl-polyfills/${external}/-/archive/${externals[$external]}/${external}-${externals[$external]}.tar.gz)
+ md5sums+=("SKIP")
+done
+
+arch=(x86_64 i386 armv7h x86_64_v3)
depends=(fmt spdlog nlohmann-json systemd)
makedepends=(cmake git)
optdepends=("ananicy-rules-git: community rules")
@@ -19,14 +29,18 @@ optdepends=("ananicy-rules-git: community rules")
prepare() {
cd "$pkgname-v${_pkgver}"
- mkdir -p build
- cd build
- cmake .. \
+ echo Externals: "${!externals[@]}"
+ for external in "${!externals[@]}"; do
+ mv -v "../${external}-${externals[$external]}/"* external/${external}/
+ done
+
+ cmake -B build -S . \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DUSE_EXTERNAL_SPDLOG=ON \
-DUSE_EXTERNAL_JSON=ON \
-DUSE_EXTERNAL_FMTLIB=ON \
+ -DENABLE_SYSTEMD=ON \
-DVERSION=${_pkgver}
}
@@ -44,4 +58,3 @@ package() {
install -m755 -d "$pkgdir/etc/ananicy.d"
}
-