summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Jung2022-11-09 00:08:45 +0100
committerPeter Jung2022-11-09 00:08:45 +0100
commit8aa46c9370541ba56458ffc9ca9f3f04f6f8f307 (patch)
treebcec7fefd66a845eabc5bf961048960996c483eb
parente11c34cdb6eef4ca3ce0e84be70b159377bf37d8 (diff)
downloadaur-8aa46c9370541ba56458ffc9ca9f3f04f6f8f307.tar.gz
Use bpf processing
Signed-off-by: Peter Jung <admin@ptr1337.dev>
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD9
2 files changed, 12 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b28bf4f5144e..8b5efcd19392 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,23 @@
pkgbase = ananicy-cpp-git
pkgdesc = Ananicy Cpp is a full rewrite of Ananicy in C++, featuring lower CPU and RAM usage.
- pkgver = 1.0.0.rc7.r33.g9a6987e
+ pkgver = 1.0.0.rc7.r60.g35cab20
pkgrel = 1
url = https://gitlab.com/ananicy-cpp/ananicy-cpp.git
arch = x86_64
arch = i386
arch = armv7h
makedepends = cmake
+ makedepends = clang
makedepends = git
- makedepends = gcc
+ makedepends = nlohmann-json
+ makedepends = bpf
depends = fmt
depends = spdlog
depends = nlohmann-json
depends = systemd
+ depends = libelf
+ depends = zlib
+ depends = libbpf
optdepends = ananicy-rules-git: community rules
optdepends = ananicy-rules: Rules based for ananicy-cpp
provides = ananicy-cpp
diff --git a/PKGBUILD b/PKGBUILD
index 22015204a0b3..12058af9759f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=ananicy-cpp-git
_pkgname=ananicy-cpp
-pkgver=1.0.0.rc7.r33.g9a6987e
+pkgver=1.0.0.rc7.r60.g35cab20
pkgrel=1
pkgdesc="Ananicy Cpp is a full rewrite of Ananicy in C++, featuring lower CPU and RAM usage."
url="https://gitlab.com/ananicy-cpp/ananicy-cpp.git"
@@ -14,13 +14,12 @@ source=(
md5sums=('SKIP'
'SKIP')
arch=(x86_64 i386 armv7h)
-depends=(fmt spdlog nlohmann-json systemd)
-makedepends=(cmake git gcc)
+depends=(fmt spdlog nlohmann-json systemd libelf zlib libbpf)
+makedepends=(cmake clang git nlohmann-json bpf)
conflicts=(ananicy-cpp)
provides=(ananicy-cpp)
optdepends=("ananicy-rules-git: community rules"
"ananicy-rules: Rules based for ananicy-cpp")
-
pkgver() {
cd "$_pkgname"
git describe --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
@@ -38,6 +37,8 @@ prepare() {
-DCMAKE_INSTALL_PREFIX=/usr \
-DUSE_EXTERNAL_SPDLOG=ON \
-DUSE_EXTERNAL_JSON=ON \
+ -DUSE_BPF_PROC_IMPL=ON \
+ -DBPF_BUILD_LIBBPF=OFF \
-DUSE_EXTERNAL_FMTLIB=ON
}