summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Jung2022-10-27 13:22:34 +0200
committerPeter Jung2022-10-27 13:22:34 +0200
commitb320305ca7f817a6aaa236a3461b3aeb8c3bd154 (patch)
treef01e7bfec87fbba138d8baab4c4e11831cd8b39b
parent5d6453bb9af94f753713adfeacdc09233ea763b0 (diff)
downloadaur-b320305ca7f817a6aaa236a3461b3aeb8c3bd154.tar.gz
Fix submodule issue
Signed-off-by: Peter Jung <admin@ptr1337.dev>
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e0dc0be1eb08..b53015fb040c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ananicy-cpp-git
pkgdesc = Ananicy Cpp is a full rewrite of Ananicy in C++, featuring lower CPU and RAM usage.
- pkgver = 1.0.0.rc5.r13.g38ad7b1
+ pkgver = 1.0.0.rc7.r33.g9a6987e
pkgrel = 1
arch = x86_64
arch = i386
diff --git a/PKGBUILD b/PKGBUILD
index 519cd6195f00..21c336481696 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,15 @@
pkgname=ananicy-cpp-git
_pkgname=ananicy-cpp
-pkgver=1.0.0.rc5.r13.g38ad7b1
+pkgver=1.0.0.rc7.r33.g9a6987e
pkgrel=1
pkgdesc="Ananicy Cpp is a full rewrite of Ananicy in C++, featuring lower CPU and RAM usage."
source=(
"git+https://gitlab.com/ananicy-cpp/ananicy-cpp.git"
"git+https://gitlab.com/ananicy-cpp/stl-polyfills/std-format.git"
)
-md5sums=('SKIP' 'SKIP')
+md5sums=('SKIP'
+ 'SKIP')
arch=(x86_64 i386 armv7h)
depends=(fmt spdlog nlohmann-json systemd)
makedepends=(cmake git gcc)
@@ -28,7 +29,7 @@ prepare() {
git submodule init
git config submodule."external/std-format".url "${srcdir}/std-format"
- git submodule update
+ git -c protocol.file.allow=always submodule update
cmake -B build -S . \
-DCMAKE_BUILD_TYPE=Release \