summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVladislav Nepogodin2022-12-28 00:50:15 +0400
committerVladislav Nepogodin2022-12-28 00:51:28 +0400
commitcf70d15c570df373977177014bb813b00c194cea (patch)
tree05319d7bedd4151fcd76551f39354282b713d16a
parent3bcf96a268540b02c4b9ef6a7fe6f176012cd4ab (diff)
downloadaur-cf70d15c570df373977177014bb813b00c194cea.tar.gz
move cmake configure step to build
don't disable strip
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD20
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8e217814b592..828d78b33561 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -24,7 +24,6 @@ pkgbase = ananicy-cpp-git
optdepends = ananicy-rules: Rules based for ananicy-cpp
provides = ananicy-cpp
conflicts = ananicy-cpp
- options = !strip
source = ananicy-cpp::git+https://gitlab.com/ananicy-cpp/ananicy-cpp.git
source = git+https://gitlab.com/vnepogodin/std-format.git
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 7b6a940a8317..65c33089797d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,7 +19,6 @@ sha512sums=('SKIP'
'SKIP')
provides=('ananicy-cpp')
conflicts=('ananicy-cpp')
-options=(!strip)
pkgver() {
cd "${srcdir}/${_pkgname}"
@@ -30,13 +29,19 @@ pkgver() {
prepare() {
cd "${_pkgname}"
- export CFLAGS="${CFLAGS}"
- export CXXFLAGS="${CXXFLAGS}"
- export LDFLAGS="${LDFLAGS}"
-
git submodule init
git config submodule."external/std-format".url "${srcdir}/std-format"
git -c protocol.file.allow=always submodule update
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+
+ _cpuCount=$(grep -c -w ^processor /proc/cpuinfo)
+
+ export CFLAGS="${CFLAGS}"
+ export CXXFLAGS="${CXXFLAGS}"
+ export LDFLAGS="${LDFLAGS}"
cmake -S . -Bbuild \
-GNinja \
@@ -47,12 +52,7 @@ prepare() {
-DUSE_BPF_PROC_IMPL=ON \
-DBPF_BUILD_LIBBPF=OFF \
-DUSE_EXTERNAL_FMTLIB=ON
-}
-build() {
- cd "${srcdir}/${_pkgname}"
-
- _cpuCount=$(grep -c -w ^processor /proc/cpuinfo)
cmake --build build --target ananicy-cpp --parallel $_cpuCount
}