summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntoine Viallon2021-05-27 18:14:02 +0200
committerAntoine Viallon2021-05-27 18:15:52 +0200
commitedb1bcdcd883179904b860cafbe6c6d9eceb22db (patch)
tree362d6445964469bd8305bebf173a86a11fbd46e3
parent50fa28583f9824351609e354e30c0066a804c7fa (diff)
downloadaur-edb1bcdcd883179904b860cafbe6c6d9eceb22db.tar.gz
Make ananicy an optional dependency
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 84c7acf2d415..b599b924f6de 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ananicy-cpp-git
pkgdesc = Ananicy Cpp is a full rewrite of Ananicy in C++, featuring lower CPU and RAM usage.
- pkgver = 0.3.0.r7.g8aec019
+ pkgver = 0.5.0.r0.g90a8529
pkgrel = 1
arch = x86_64
arch = i386
@@ -8,11 +8,11 @@ pkgbase = ananicy-cpp-git
makedepends = cmake
makedepends = git
makedepends = gcc
- depends = ananicy
depends = fmt
depends = spdlog
depends = nlohmann-json
depends = systemd
+ optdepends = ananicy: community rules
provides = ananicy-cpp
conflicts = ananicy-cpp
source = git+https://gitlab.com/aviallon/ananicy-cpp.git
diff --git a/PKGBUILD b/PKGBUILD
index b6f34698588a..0fd6f2e8c174 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,17 @@
pkgname=ananicy-cpp-git
_pkgname=ananicy-cpp
-pkgver=0.3.0.r7.g8aec019
+pkgver=0.5.0.r0.g90a8529
pkgrel=1
pkgdesc="Ananicy Cpp is a full rewrite of Ananicy in C++, featuring lower CPU and RAM usage."
source=("git+https://gitlab.com/aviallon/ananicy-cpp.git")
-md5sums=(SKIP)
+md5sums=('SKIP')
arch=(x86_64 i386 armv7h)
-depends=(ananicy fmt spdlog nlohmann-json systemd)
+depends=(fmt spdlog nlohmann-json systemd)
makedepends=(cmake git gcc)
conflicts=(ananicy-cpp)
provides=(ananicy-cpp)
+optdepends=("ananicy: community rules")
pkgver() {
cd "$_pkgname"
@@ -40,5 +41,7 @@ package() {
cd "$_pkgname/build"
export DESTDIR="$pkgdir"
cmake --install .
+
+ install -m755 -d "$pkgdir/etc/ananicy.d"
}