summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNamkhai B2021-12-11 16:51:09 -0600
committerNamkhai B2021-12-11 16:51:09 -0600
commit3f7742497b4fc1064a4ef9282b998f4d19d821f7 (patch)
treecd81cd7826392de2847392894b153276c4e13f6b
parentb8e553f6d6822d789b2808c184144357ab0cbea0 (diff)
downloadaur-3f7742497b4fc1064a4ef9282b998f4d19d821f7.tar.gz
Update to v1.0.0-rc5 & adopt package
-rw-r--r--PKGBUILD23
1 files changed, 11 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index be0f7511d8bf..b0d085d50abf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,24 @@
-# Maintainer: Daniel Menelkir <menelkir@itroll.org>
+# Maintainer: Namkhai B. <echo bmFta2hhaS5uM0Bwcm90b25tYWlsLmNvbQo= | base64 -d>
+_pkgname=ananicy-cpp
pkgname=ananicy-cpp-nosystemd
-pkgver=0.5.1
+_pkgver=1.0.0-rc5
+pkgver=${_pkgver//-/.}
pkgrel=1
pkgdesc="Ananicy Cpp is a full rewrite of Ananicy in C++, featuring lower CPU and RAM usage."
url="https://gitlab.com/ananicy-cpp/ananicy-cpp/"
license=(GPLv3)
source=(
- "https://gitlab.com/ananicy-cpp/ananicy-cpp/-/archive/v${pkgver}/ananicy-cpp-v${pkgver}.tar.gz"
+ "https://gitlab.com/ananicy-cpp/${_pkgname}/-/archive/v${_pkgver}/${_pkgname}-v${_pkgver}.tar.gz"
)
-md5sums=('5b16dc5595778fb8011837cfc2ab6ca1')
+md5sums=('6d8caf9cb384e053df54d795102beb1d')
arch=(x86_64 i386 armv7h)
depends=(fmt spdlog nlohmann-json)
makedepends=(cmake git)
-optdepends=("ananicy-nosystemd-git: community rules")
+optdepends=("ananicy-rules-git: community rules")
prepare() {
- cd "ananicy-cpp-v${pkgver}"
+ cd "$_pkgname-v${_pkgver}"
mkdir -p build
cd build
@@ -27,23 +29,20 @@ prepare() {
-DUSE_EXTERNAL_JSON=ON \
-DUSE_EXTERNAL_FMTLIB=ON \
-DENABLE_SYSTEMD=OFF \
- -DOPTIMIZE_FOR_NATIVE_MICROARCH=ON \
- -DVERSION=${pkgver}
+ -DVERSION=${_pkgver}
}
build() {
- cd "ananicy-cpp-v${pkgver}/build"
+ cd "$_pkgname-v${_pkgver}/build"
cmake --build .
}
package() {
- cd "ananicy-cpp-v${pkgver}/build"
+ cd "$_pkgname-v${_pkgver}/build"
export DESTDIR="$pkgdir"
cmake --install .
install -m755 -d "$pkgdir/etc/ananicy.d"
}
-
-