summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Menelkir2021-05-29 17:07:46 -0300
committerDaniel Menelkir2021-05-29 17:07:46 -0300
commitaca0f10b4e613a2b8272f85b01665fca930a5327 (patch)
treef15ce3b62e3fd8eb15680c3db604b694289a5192
parentb1a14755c6c5a3a6e7cb0ed8fee7aefb110be723 (diff)
downloadaur-aca0f10b4e613a2b8272f85b01665fca930a5327.tar.gz
First commit
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5a4e091b0685..7992f2fcb56e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,4 +1,4 @@
-pkgbase = ananicy-cpp
+pkgbase = ananicy-cpp-nosystemd
pkgdesc = Ananicy Cpp is a full rewrite of Ananicy in C++, featuring lower CPU and RAM usage.
pkgver = 0.5.1
pkgrel = 1
@@ -16,5 +16,5 @@ pkgbase = ananicy-cpp
source = https://gitlab.com/ananicy-cpp/ananicy-cpp/-/archive/v0.5.1/ananicy-cpp-v0.5.1.tar.gz
md5sums = 5b16dc5595778fb8011837cfc2ab6ca1
-pkgname = ananicy-cpp
+pkgname = ananicy-cpp-nosystemd
diff --git a/PKGBUILD b/PKGBUILD
index de5cde5b676b..c456fec03436 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Daniel Menelkir <menelkir@itroll.org>
-pkgname=ananicy-cpp
+pkgname=ananicy-cpp-nosystemd
pkgver=0.5.1
pkgrel=1
pkgdesc="Ananicy Cpp is a full rewrite of Ananicy in C++, featuring lower CPU and RAM usage."
url="https://gitlab.com/ananicy-cpp/ananicy-cpp/"
license=(GPLv3)
source=(
- "https://gitlab.com/ananicy-cpp/${pkgname}/-/archive/v${pkgver}/${pkgname}-v${pkgver}.tar.gz"
+ "https://gitlab.com/ananicy-cpp/ananicy-cpp/-/archive/v${pkgver}/ananicy-cpp-v${pkgver}.tar.gz"
)
md5sums=('5b16dc5595778fb8011837cfc2ab6ca1')
arch=(x86_64 i386 armv7h)
@@ -16,7 +16,7 @@ makedepends=(cmake git)
optdepends=("ananicy: community rules")
prepare() {
- cd "$pkgname-v${pkgver}"
+ cd "ananicy-cpp-v${pkgver}"
mkdir -p build
cd build
@@ -32,13 +32,13 @@ prepare() {
}
build() {
- cd "$pkgname-v${pkgver}/build"
+ cd "ananicy-cpp-v${pkgver}/build"
cmake --build .
}
package() {
- cd "$pkgname-v${pkgver}/build"
+ cd "ananicy-cpp-v${pkgver}/build"
export DESTDIR="$pkgdir"
cmake --install .