summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Menelkir2021-05-29 17:03:34 -0300
committerDaniel Menelkir2021-05-29 17:03:34 -0300
commitb1a14755c6c5a3a6e7cb0ed8fee7aefb110be723 (patch)
treeb39459f678c1a853a96bf5b6ba54999484b5382f
downloadaur-b1a14755c6c5a3a6e7cb0ed8fee7aefb110be723.tar.gz
first commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD49
2 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5a4e091b0685
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = ananicy-cpp
+ pkgdesc = Ananicy Cpp is a full rewrite of Ananicy in C++, featuring lower CPU and RAM usage.
+ pkgver = 0.5.1
+ pkgrel = 1
+ url = https://gitlab.com/ananicy-cpp/ananicy-cpp/
+ arch = x86_64
+ arch = i386
+ arch = armv7h
+ license = GPLv3
+ makedepends = cmake
+ makedepends = git
+ depends = fmt
+ depends = spdlog
+ depends = nlohmann-json
+ optdepends = ananicy: community rules
+ source = https://gitlab.com/ananicy-cpp/ananicy-cpp/-/archive/v0.5.1/ananicy-cpp-v0.5.1.tar.gz
+ md5sums = 5b16dc5595778fb8011837cfc2ab6ca1
+
+pkgname = ananicy-cpp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..de5cde5b676b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Daniel Menelkir <menelkir@itroll.org>
+
+pkgname=ananicy-cpp
+pkgver=0.5.1
+pkgrel=1
+pkgdesc="Ananicy Cpp is a full rewrite of Ananicy in C++, featuring lower CPU and RAM usage."
+url="https://gitlab.com/ananicy-cpp/ananicy-cpp/"
+license=(GPLv3)
+source=(
+ "https://gitlab.com/ananicy-cpp/${pkgname}/-/archive/v${pkgver}/${pkgname}-v${pkgver}.tar.gz"
+ )
+md5sums=('5b16dc5595778fb8011837cfc2ab6ca1')
+arch=(x86_64 i386 armv7h)
+depends=(fmt spdlog nlohmann-json)
+makedepends=(cmake git)
+optdepends=("ananicy: community rules")
+
+prepare() {
+ cd "$pkgname-v${pkgver}"
+
+ mkdir -p build
+ cd build
+ cmake .. \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DUSE_EXTERNAL_SPDLOG=ON \
+ -DUSE_EXTERNAL_JSON=ON \
+ -DUSE_EXTERNAL_FMTLIB=ON \
+ -DENABLE_SYSTEMD=OFF \
+ -DOPTIMIZE_FOR_NATIVE_MICROARCH=ON \
+ -DVERSION=${pkgver}
+}
+
+build() {
+ cd "$pkgname-v${pkgver}/build"
+
+ cmake --build .
+}
+
+package() {
+ cd "$pkgname-v${pkgver}/build"
+
+ export DESTDIR="$pkgdir"
+ cmake --install .
+
+ install -m755 -d "$pkgdir/etc/ananicy.d"
+}
+
+