summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFunami2024-09-20 12:06:47 +0200
committerFunami2024-09-20 12:08:05 +0200
commit25ea41388073dcb0670aca9de5f0ffb35968faf3 (patch)
tree10d001d980e1a9d3346a4fcb40fa961cf005158d
downloadaur-25ea41388073dcb0670aca9de5f0ffb35968faf3.tar.gz
initial commit
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD42
-rw-r--r--ananicy-cpp-log.consumer-for1
-rw-r--r--ananicy-cpp-log.notification-fd1
-rw-r--r--ananicy-cpp-log.pipeline-name1
-rw-r--r--ananicy-cpp-log.run9
-rw-r--r--ananicy-cpp-log.type1
-rw-r--r--ananicy-cpp-srv.producer-for1
-rw-r--r--ananicy-cpp-srv.run3
-rw-r--r--ananicy-cpp-srv.type1
-rw-r--r--ananicy-cpp.conf2
11 files changed, 92 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1cfa32127d06
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = ananicy-cpp-s6
+ pkgdesc = s6-rc service scripts for ananicy-cpp
+ pkgver = 20240920
+ pkgrel = 1
+ arch = any
+ depends = ananicy-cpp-nosystemd
+ depends = s6
+ provides = init-ananicy-cpp
+ conflicts = init-ananicy-cpp
+ backup = etc/s6/config/ananicy-cpp.conf
+ source = ananicy-cpp.conf
+ source = ananicy-cpp-log.consumer-for
+ source = ananicy-cpp-log.notification-fd
+ source = ananicy-cpp-log.pipeline-name
+ source = ananicy-cpp-log.run
+ source = ananicy-cpp-log.type
+ source = ananicy-cpp-srv.producer-for
+ source = ananicy-cpp-srv.run
+ source = ananicy-cpp-srv.type
+ sha256sums = 8a3d2abcc40d355ca913f39871d24f6c770dd216fe075d2548e729b2ae952135
+ sha256sums = daeda4c9b28413aa81454c3c6b23580bc0c946190c619134d62cffb11f05d1b9
+ sha256sums = 1121cfccd5913f0a63fec40a6ffd44ea64f9dc135c66634ba001d10bcf4302a2
+ sha256sums = bf9877c2702063e6d44feab829ca70bee75086981724a93edea1a920d3a76998
+ sha256sums = 07f935b35f3096a165374d9d5fec90339755ac58d6bbf8dd41b1282bb9600fd5
+ sha256sums = d0001a150b83f68f09004c5059045cb76a3f064eed4d42ce072bc3722c118006
+ sha256sums = 69a946e03c7f201651502761598a2fb62cb9d43d6e16e111094f7b3fe1b6cbed
+ sha256sums = 2ba1503c15087a888ea5401dd243659f9d80dd2cbed4f48f6ccab00824c29bdd
+ sha256sums = d0001a150b83f68f09004c5059045cb76a3f064eed4d42ce072bc3722c118006
+
+pkgname = ananicy-cpp-s6
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ab89f39451b7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Funami
+pkgname=ananicy-cpp-s6
+pkgver=20240920
+pkgrel=1
+pkgdesc="s6-rc service scripts for ananicy-cpp"
+arch=('any')
+depends=('ananicy-cpp-nosystemd' 's6')
+provides=('init-ananicy-cpp')
+conflicts=('init-ananicy-cpp')
+backup=('etc/s6/config/ananicy-cpp.conf')
+source=('ananicy-cpp.conf'
+ 'ananicy-cpp-log.consumer-for'
+ 'ananicy-cpp-log.notification-fd'
+ 'ananicy-cpp-log.pipeline-name'
+ 'ananicy-cpp-log.run'
+ 'ananicy-cpp-log.type'
+ 'ananicy-cpp-srv.producer-for'
+ 'ananicy-cpp-srv.run'
+ 'ananicy-cpp-srv.type')
+sha256sums=('8a3d2abcc40d355ca913f39871d24f6c770dd216fe075d2548e729b2ae952135'
+ 'daeda4c9b28413aa81454c3c6b23580bc0c946190c619134d62cffb11f05d1b9'
+ '1121cfccd5913f0a63fec40a6ffd44ea64f9dc135c66634ba001d10bcf4302a2'
+ 'bf9877c2702063e6d44feab829ca70bee75086981724a93edea1a920d3a76998'
+ '07f935b35f3096a165374d9d5fec90339755ac58d6bbf8dd41b1282bb9600fd5'
+ 'd0001a150b83f68f09004c5059045cb76a3f064eed4d42ce072bc3722c118006'
+ '69a946e03c7f201651502761598a2fb62cb9d43d6e16e111094f7b3fe1b6cbed'
+ '2ba1503c15087a888ea5401dd243659f9d80dd2cbed4f48f6ccab00824c29bdd'
+ 'd0001a150b83f68f09004c5059045cb76a3f064eed4d42ce072bc3722c118006')
+
+_inst_sv() {
+ for file in consumer-for notification-fd pipeline-name producer-for run type; do
+ if test -f "$1.$file"; then
+ install -Dm644 "$1.$file" "$pkgdir/etc/s6/sv/$1/$file"
+ fi
+ done
+}
+
+package() {
+ _inst_sv 'ananicy-cpp-log'
+ _inst_sv 'ananicy-cpp-srv'
+ install -Dm644 "ananicy-cpp.conf" -t "$pkgdir/etc/s6/config"
+}
diff --git a/ananicy-cpp-log.consumer-for b/ananicy-cpp-log.consumer-for
new file mode 100644
index 000000000000..cbe856112f5e
--- /dev/null
+++ b/ananicy-cpp-log.consumer-for
@@ -0,0 +1 @@
+ananicy-cpp-srv
diff --git a/ananicy-cpp-log.notification-fd b/ananicy-cpp-log.notification-fd
new file mode 100644
index 000000000000..00750edc07d6
--- /dev/null
+++ b/ananicy-cpp-log.notification-fd
@@ -0,0 +1 @@
+3
diff --git a/ananicy-cpp-log.pipeline-name b/ananicy-cpp-log.pipeline-name
new file mode 100644
index 000000000000..f36d38029365
--- /dev/null
+++ b/ananicy-cpp-log.pipeline-name
@@ -0,0 +1 @@
+ananicy-cpp
diff --git a/ananicy-cpp-log.run b/ananicy-cpp-log.run
new file mode 100644
index 000000000000..c7cc34d53592
--- /dev/null
+++ b/ananicy-cpp-log.run
@@ -0,0 +1,9 @@
+#!/bin/execlineb -P
+envfile /etc/s6/config/ananicy-cpp.conf
+importas -sCuD "n3 s2000000 T" DIRECTIVES DIRECTIVES
+ifelse { test -w /var/log } {
+ foreground { install -d -o s6log -g s6log /var/log/ananicy-cpp }
+ s6-setuidgid s6log exec -c s6-log -d3 -b -- ${DIRECTIVES} /var/log/ananicy-cpp
+}
+foreground { install -d -o s6log -g s6log /run/log/ananicy-cpp }
+s6-setuidgid s6log exec -c s6-log -d3 -b -- ${DIRECTIVES} /run/log/ananicy-cpp
diff --git a/ananicy-cpp-log.type b/ananicy-cpp-log.type
new file mode 100644
index 000000000000..5883cff0cd15
--- /dev/null
+++ b/ananicy-cpp-log.type
@@ -0,0 +1 @@
+longrun
diff --git a/ananicy-cpp-srv.producer-for b/ananicy-cpp-srv.producer-for
new file mode 100644
index 000000000000..5425afe0d63d
--- /dev/null
+++ b/ananicy-cpp-srv.producer-for
@@ -0,0 +1 @@
+ananicy-cpp-log
diff --git a/ananicy-cpp-srv.run b/ananicy-cpp-srv.run
new file mode 100644
index 000000000000..b0a889bf9c37
--- /dev/null
+++ b/ananicy-cpp-srv.run
@@ -0,0 +1,3 @@
+#!/bin/execlineb -P
+fdmove -c 2 1
+exec /usr/bin/ananicy-cpp start
diff --git a/ananicy-cpp-srv.type b/ananicy-cpp-srv.type
new file mode 100644
index 000000000000..5883cff0cd15
--- /dev/null
+++ b/ananicy-cpp-srv.type
@@ -0,0 +1 @@
+longrun
diff --git a/ananicy-cpp.conf b/ananicy-cpp.conf
new file mode 100644
index 000000000000..565bdae8e3ff
--- /dev/null
+++ b/ananicy-cpp.conf
@@ -0,0 +1,2 @@
+# This configures the directives used for s6-log in the log service.
+DIRECTIVES="n3 s2000000 T"