summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2021-01-17 13:50:25 -0500
committerVincent Grande2021-01-17 13:50:25 -0500
commita6cdb0da0781f72ebee29273d455e39efbf940c8 (patch)
treefbb5c9628e1e5541fe1bb8c204a708941e0e94ce
downloadaur-a6cdb0da0781f72ebee29273d455e39efbf940c8.tar.gz
initial upload
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD29
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a50b1aab5d6a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = ananicy-nosystemd-git
+ pkgdesc = Ananicy - is Another auto nice daemon, with community rules support
+ pkgver = 2.1.0.r12.g38eb477
+ pkgrel = 1
+ url = https://github.com/Nefelim4ag/Ananicy
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = make
+ depends = bash
+ depends = schedtool
+ depends = python
+ provides = ananicy
+ conflicts = ananicy
+ backup = etc/ananicy.d/ananicy.conf
+ source = git+https://github.com/Nefelim4ag/Ananicy.git#branch=master
+ md5sums = SKIP
+
+pkgname = ananicy-nosystemd-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..97112ab28f39
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Vincent Grande <shoober420@gmail.com>
+# Contributor: Timofey Titovets <nefelim4ag@gmail.com>
+
+pkgname=ananicy-nosystemd-git
+pkgver=2.1.0.r12.g38eb477
+pkgrel=1
+pkgdesc="Ananicy - is Another auto nice daemon, with community rules support"
+arch=('any')
+url="https://github.com/Nefelim4ag/Ananicy"
+license=('GPL3')
+depends=('bash' 'schedtool' 'python')
+makedepends=('git' 'make')
+provides=(ananicy)
+conflicts=(ananicy)
+source=(git+https://github.com/Nefelim4ag/Ananicy.git#branch=master)
+md5sums=('SKIP')
+backup=('etc/ananicy.d/ananicy.conf')
+
+pkgver() {
+ cd ananicy
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd ananicy
+ make install PREFIX="$pkgdir"
+ mkdir -p "$pkgdir/usr/"
+ mv -v "$pkgdir/lib" "$pkgdir/usr/"
+}