summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIwan Timmer2020-11-03 18:19:27 +0100
committerIwan Timmer2020-11-03 18:19:27 +0100
commit0c9a9385694e680f5b277ca6f9326ad5d5df7dd3 (patch)
treeba940322a1ee3cbfec676d1d5e883c8f98ed4bbb
parent2009157b08d4714f116935234366df7ce313e81a (diff)
downloadaur-0c9a9385694e680f5b277ca6f9326ad5d5df7dd3.tar.gz
remove anbox-modules-dkms-git
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD29
2 files changed, 13 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7a1bd12e906f..25b309cf8efe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,6 @@
pkgbase = anbox-git
- pkgver = r1240.c1e7550
+ pkgdesc = Running Android in a container
+ pkgver = r1292.7f1bfaf
pkgrel = 1
epoch = 1
url = http://anbox.io/
@@ -15,8 +16,13 @@ pkgbase = anbox-git
makedepends = properties-cpp
makedepends = gtest
makedepends = python2
+ depends = lxc
+ depends = sdl2_image
+ depends = protobuf
+ depends = anbox-image
+ depends = libsystemd
+ depends = boost-libs
source = git+https://github.com/anbox/anbox.git
- source = git+https://github.com/anbox/anbox-modules.git
source = git+https://github.com/google/cpu_features.git
source = git+https://github.com/Kistler-Group/sdbus-cpp.git
source = anbox-container-manager.service
@@ -29,7 +35,6 @@ pkgbase = anbox-git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = SKIP
sha256sums = 5be94b63dc30d141f15ca7d1be6e3e81f26ef33f844614975537562f5d08236c
sha256sums = 1f22dbb5a3ca6925bbf62899cd0f0bbaa0b77c879adcdd12ff9d43adfa61b1d8
sha256sums = 210eb93342228168f7bb632c8b93d9bfda6f53f62459a6b74987fa1e17530475
@@ -39,17 +44,4 @@ pkgbase = anbox-git
sha256sums = 559190df4d6d595480b30d8b13b862081fc4aac52790e33eb24cf7fbcb8003b8
pkgname = anbox-git
- pkgdesc = Running Android in a container
- depends = lxc
- depends = sdl2_image
- depends = protobuf
- depends = anbox-image
- depends = libsystemd
- depends = boost-libs
- optdepends = anbox-modules-dkms-git: Required Android kernel modules
-
-pkgname = anbox-modules-dkms-git
- pkgdesc = Required kernel module sources for Android
- arch = any
- depends = dkms
diff --git a/PKGBUILD b/PKGBUILD
index 24f69a750d78..2bfd033f9232 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
# Maintainer: Iwan Timmer <irtimmer@gmail.com>
-pkgname=('anbox-git' 'anbox-modules-dkms-git')
+pkgname=anbox-git
_pkgname=anbox
-pkgver=r1240.c1e7550
+pkgver=r1292.7f1bfaf
pkgrel=1
epoch=1
arch=('x86_64')
url="http://anbox.io/"
license=('GPL3')
+pkgdesc="Running Android in a container"
+depends=('lxc' 'sdl2_image' 'protobuf' 'anbox-image' 'libsystemd' 'boost-libs')
makedepends=('cmake' 'git' 'glm' 'lxc' 'sdl2_image' 'protobuf' 'boost' 'properties-cpp' 'gtest' 'python2')
source=("git+https://github.com/anbox/anbox.git"
- "git+https://github.com/anbox/anbox-modules.git"
"git+https://github.com/google/cpu_features.git"
"git+https://github.com/Kistler-Group/sdbus-cpp.git"
'anbox-container-manager.service'
@@ -23,7 +24,6 @@ source=("git+https://github.com/anbox/anbox.git"
sha256sums=('SKIP'
'SKIP'
'SKIP'
- 'SKIP'
'5be94b63dc30d141f15ca7d1be6e3e81f26ef33f844614975537562f5d08236c'
'1f22dbb5a3ca6925bbf62899cd0f0bbaa0b77c879adcdd12ff9d43adfa61b1d8'
'210eb93342228168f7bb632c8b93d9bfda6f53f62459a6b74987fa1e17530475'
@@ -61,11 +61,7 @@ build() {
make
}
-package_anbox-git() {
- depends=('lxc' 'sdl2_image' 'protobuf' 'anbox-image' 'libsystemd' 'boost-libs')
- optdepends=('anbox-modules-dkms-git: Required Android kernel modules')
- pkgdesc="Running Android in a container"
-
+package() {
cd "$srcdir/${_pkgname}"
make -C build DESTDIR="$pkgdir" install
@@ -77,18 +73,3 @@ package_anbox-git() {
install -Dm 644 -t $pkgdir/usr/share/applications $srcdir/anbox.desktop
install -Dm 644 snap/gui/icon.png $pkgdir/usr/share/pixmaps/anbox.png
}
-
-package_anbox-modules-dkms-git() {
- pkgdesc="Required kernel module sources for Android"
- depends=('dkms')
- arch=('any')
-
- cd "$srcdir/anbox-modules"
- modules=(ashmem binder)
- for mod in "${modules[@]}"; do
- install -dm 755 $pkgdir/usr/src
- cp -a $mod $pkgdir/usr/src/anbox-modules-$mod-$pkgver
- done;
-
- install -Dm 644 -t $pkgdir/usr/lib/modules-load.d $srcdir/anbox.conf
-}