summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryochananmarqos2019-07-23 08:53:39 -0600
committeryochananmarqos2019-07-23 08:53:39 -0600
commit2f3db4df800ff2ca0ee2345a9eaf7d4353876c6a (patch)
tree26e57e9df46811aed8aa48b344d7d496090c71a9
parent71543d5cd1dcf69c944d7fb9cf515919b5aa5328 (diff)
downloadaur-2f3db4df800ff2ca0ee2345a9eaf7d4353876c6a.tar.gz
update checksums for opengapps 20190723
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD45
2 files changed, 25 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7ba7c98a55fb..fb97a7e2a921 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -13,17 +13,17 @@ pkgbase = anbox-image-gapps
provides = anbox-image
conflicts = anbox-image
noextract = android_amd64.img
- noextract = open_gapps-x86_64-7.1-mini-20190720.zip
+ noextract = open_gapps-x86_64-7.1-mini-20190723.zip
noextract = houdini_y.sfs
noextract = houdini_z.sfs
noextract = libhoudini.so
source = https://build.anbox.io/android-images/2018/07/19/android_amd64.img
- source = https://github.com/opengapps/x86_64/releases/download/20190720/open_gapps-x86_64-7.1-mini-20190720.zip
+ source = https://github.com/opengapps/x86_64/releases/download/20190723/open_gapps-x86_64-7.1-mini-20190723.zip
source = houdini_y.sfs::http://dl.android-x86.org/houdini/7_y/houdini.sfs
source = houdini_z.sfs::http://dl.android-x86.org/houdini/7_z/houdini.sfs
source = https://github.com/Rprop/libhoudini/raw/master/4.0.8.45720/system/lib/libhoudini.so
sha256sums = 6b04cd33d157814deaf92dccf8a23da4dc00b05ca6ce982a03830381896a8cca
- sha256sums = 552e78b197551e94ed78c405fc5d0660239791c99b81bbb2fd651c4e5c309593
+ sha256sums = 89fce04f5bc99b213955d0a4c2fdddffd2a039dc4034fc967ce372646be90187
sha256sums = 56fd08c448840578386a71819c07139122f0af39f011059ce728ea0f3c60b665
sha256sums = 7eedc42015e6fb84a11a406a099241efccc20d4e020d476335a5fdb6e69a33d2
sha256sums = 2d15d126e46ea933a92fcc6dd30ad2c93d063af322fc1ba84aaa4f3e75d84e68
diff --git a/PKGBUILD b/PKGBUILD
index 606797f48b27..3df0e3d4be68 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -34,7 +34,7 @@ noextract=('android_amd64.img'
'houdini_z.sfs'
'libhoudini.so')
sha256sums=('6b04cd33d157814deaf92dccf8a23da4dc00b05ca6ce982a03830381896a8cca'
- '552e78b197551e94ed78c405fc5d0660239791c99b81bbb2fd651c4e5c309593'
+ '89fce04f5bc99b213955d0a4c2fdddffd2a039dc4034fc967ce372646be90187'
'56fd08c448840578386a71819c07139122f0af39f011059ce728ea0f3c60b665'
'7eedc42015e6fb84a11a406a099241efccc20d4e020d476335a5fdb6e69a33d2'
'2d15d126e46ea933a92fcc6dd30ad2c93d063af322fc1ba84aaa4f3e75d84e68')
@@ -56,10 +56,10 @@ build () {
cd "${srcdir}"
- cp -r ./$(find opengapps -type d -name "PrebuiltGmsCore") ./squashfs-root/system/priv-app/
- cp -r ./$(find opengapps -type d -name "GoogleLoginService") ./squashfs-root/system/priv-app/
- cp -r ./$(find opengapps -type d -name "Phonesky") ./squashfs-root/system/priv-app/
- cp -r ./$(find opengapps -type d -name "GoogleServicesFramework") ./squashfs-root/system/priv-app/
+ cp -r ./$(find opengapps -type d -name "PrebuiltGmsCore") ./squashfs-root/system/priv-app/
+ cp -r ./$(find opengapps -type d -name "GoogleLoginService") ./squashfs-root/system/priv-app/
+ cp -r ./$(find opengapps -type d -name "Phonesky") ./squashfs-root/system/priv-app/
+ cp -r ./$(find opengapps -type d -name "GoogleServicesFramework") ./squashfs-root/system/priv-app/
# load houdini_y
mkdir -p houdini_y
@@ -110,23 +110,23 @@ build () {
END
)
- _C=$(echo ${_C} | sed 's/\//\\\//g')
- _C=$(echo ${_C} | sed 's/\"/\\\"/g')
- sed -i "/<\/permissions>/ s/.*/${_C}\n&/" ./squashfs-root/system/etc/permissions/anbox.xml
+ _C=$(echo ${_C} | sed 's/\//\\\//g')
+ _C=$(echo ${_C} | sed 's/\"/\\\"/g')
+ sed -i "/<\/permissions>/ s/.*/${_C}\n&/" ./squashfs-root/system/etc/permissions/anbox.xml
- # make wifi and bt available
- sed -i "/<unavailable-feature name=\"android.hardware.wifi\" \/>/d" ./squashfs-root/system/etc/permissions/anbox.xml
- sed -i "/<unavailable-feature name=\"android.hardware.bluetooth\" \/>/d" ./squashfs-root/system/etc/permissions/anbox.xml
+ # make wifi and bt available
+ sed -i "/<unavailable-feature name=\"android.hardware.wifi\" \/>/d" ./squashfs-root/system/etc/permissions/anbox.xml
+ sed -i "/<unavailable-feature name=\"android.hardware.bluetooth\" \/>/d" ./squashfs-root/system/etc/permissions/anbox.xml
- # set processors
- sed -i "/^ro.product.cpu.abilist=x86_64,x86/ s/$/,armeabi-v7a,armeabi,arm64-v8a/" ./squashfs-root/system/build.prop
- sed -i "/^ro.product.cpu.abilist32=x86/ s/$/,armeabi-v7a,armeabi/" ./squashfs-root/system/build.prop
- sed -i "/^ro.product.cpu.abilist64=x86_64/ s/$/,arm64-v8a/" ./squashfs-root/system/build.prop
+ # set processors
+ sed -i "/^ro.product.cpu.abilist=x86_64,x86/ s/$/,armeabi-v7a,armeabi,arm64-v8a/" ./squashfs-root/system/build.prop
+ sed -i "/^ro.product.cpu.abilist32=x86/ s/$/,armeabi-v7a,armeabi/" ./squashfs-root/system/build.prop
+ sed -i "/^ro.product.cpu.abilist64=x86_64/ s/$/,arm64-v8a/" ./squashfs-root/system/build.prop
- echo "persist.sys.nativebridge=1" >> ./squashfs-root/system/build.prop
+ echo "persist.sys.nativebridge=1" >> ./squashfs-root/system/build.prop
- # enable opengles
- echo "ro.opengles.version=131072" >> ./squashfs-root/system/build.prop
+ # enable opengles
+ echo "ro.opengles.version=131072" >> ./squashfs-root/system/build.prop
}
package() {
@@ -139,11 +139,10 @@ package() {
chown -R 100000:100000 ./squashfs-root/system/lib64/libhoudini.so
chown -R 100000:100000 ./squashfs-root/system/etc/binfmt_misc
- # squash image
- cd "${srcdir}"
- mksquashfs squashfs-root android.img -b 131072 -comp xz -Xbcj x86
-
- #install image
+ # squash image
+ mksquashfs squashfs-root android.img -b 131072 -comp xz -Xbcj x86
+
+ #install image
install -Dm644 ./android.img "${pkgdir}/"var/lib/anbox/android.img
}