summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXnopyt2020-11-19 21:43:27 +0000
committerXnopyt2020-11-19 21:48:49 +0000
commitc988eae227b751933c246c3113bda5b03b72e1ec (patch)
tree361525633cc1f8a11c5d9bdf2249e227f1a26ef4
parent50ac8215214b830c264f338bd10c5966878b71d5 (diff)
downloadaur-c988eae227b751933c246c3113bda5b03b72e1ec.tar.gz
Add Xposed Support
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD35
2 files changed, 43 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f567df7e12da..2e0a48f0f431 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
-pkgbase = anbox-image-gapps-magisk
- pkgdesc = Android image for running in Anbox, with OpenGApps, Houdini and Magisk (Bootless)
+pkgbase = anbox-image-gapps-magisk-xposed
+ pkgdesc = Android image for running in Anbox, with OpenGApps, Houdini, Xposed Framework and Magisk (Bootless)
pkgver = 2018.07.19
- pkgrel = 17
+ pkgrel = 1
url = https://anbox.io
arch = x86_64
license = custom
@@ -11,10 +11,13 @@ pkgbase = anbox-image-gapps-magisk
makedepends = unzip
provides = anbox-image
conflicts = anbox-image
+ noextract = XposedInstaller_3.1.5.apk
source = https://build.anbox.io/android-images/2018/07/19/android_amd64.img
source = https://github.com/redchenjs/aur-packages/raw/master/anbox-image/houdini_y.sfs
source = https://github.com/redchenjs/aur-packages/raw/master/anbox-image/houdini_z.sfs
source = https://github.com/topjohnwu/Magisk/releases/download/v20.4/Magisk-v20.4.zip
+ source = https://github.com/youling257/XposedTools/files/1931996/xposed-x86_64.zip
+ source = XposedInstaller_3.1.5.apk::https://forum.xda-developers.com/attachment.php?attachmentid=4393082&d=1516301692
source = magisk-init-rc.patch
source = init-magisk.sh
source = https://xnopyt.info/busybox
@@ -22,11 +25,13 @@ pkgbase = anbox-image-gapps-magisk
source = media_codecs_google_video.xml
source = media_codecs_google_audio.xml
source = media_codecs_google_telephony.xml
- source = https://downloads.sourceforge.net/project/opengapps/x86_64/20201031/open_gapps-x86_64-7.1-pico-20201031.zip
+ source = https://downloads.sourceforge.net/project/opengapps/x86_64/20201119/open_gapps-x86_64-7.1-pico-20201119.zip
md5sums = 26874452a6521ec2e37400670d438e33
md5sums = 7ebf618b1af94a02322d9f2d2610090b
md5sums = 5ca37e1629edb7d13b18751b72dc98ad
md5sums = 9503fc692e03d60cb8897ff2753c193f
+ md5sums = 86ffee229b724a8019cc78c5e221c24f
+ md5sums = 315362d994986e6584203fca282f4472
md5sums = 52959db8bc730ee3b7ab2cff7d41b299
md5sums = 4720f9c1a7df7cf05cbbeecdd43797e4
md5sums = bc3143a5e334402261bf0c703db5deac
@@ -34,7 +39,7 @@ pkgbase = anbox-image-gapps-magisk
md5sums = 599598e70060eb74c119cf7dac0ce466
md5sums = 43193761081a04ca18a28d4a6e039950
md5sums = 91f5f3e5c31f8e221ae8f318527dcb83
- md5sums = 70dd3f86493c94e8aabd0827d20d63b3
+ md5sums = 1080ea349a28021144de11440cffa136
-pkgname = anbox-image-gapps-magisk
+pkgname = anbox-image-gapps-magisk-xposed
diff --git a/PKGBUILD b/PKGBUILD
index 3622043f6c9f..8080fc4d4b80 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,10 +3,10 @@
# Contributor: Mark Wagie <mark dot wagie at tutanota dot com>
# Contributor: Robosky <fangyuhao0612 at gmail dot com>
-pkgname=anbox-image-gapps-magisk
+pkgname=anbox-image-gapps-magisk-xposed
pkgver=2018.07.19
-pkgrel=17
-pkgdesc="Android image for running in Anbox, with OpenGApps, Houdini and Magisk (Bootless)"
+pkgrel=1
+pkgdesc="Android image for running in Anbox, with OpenGApps, Houdini, Xposed Framework and Magisk (Bootless)"
arch=('x86_64')
url="https://anbox.io"
license=('custom')
@@ -28,6 +28,8 @@ source=(
"https://github.com/redchenjs/aur-packages/raw/master/anbox-image/houdini_y.sfs"
"https://github.com/redchenjs/aur-packages/raw/master/anbox-image/houdini_z.sfs"
"https://github.com/topjohnwu/Magisk/releases/download/v20.4/Magisk-v20.4.zip"
+ "https://github.com/youling257/XposedTools/files/1931996/xposed-x86_64.zip"
+ "XposedInstaller_3.1.5.apk::https://forum.xda-developers.com/attachment.php?attachmentid=4393082&d=1516301692"
"magisk-init-rc.patch"
"init-magisk.sh"
"https://xnopyt.info/busybox"
@@ -37,11 +39,16 @@ source=(
"media_codecs_google_telephony.xml"
"$_gapps_src"
)
+
+noextract=('XposedInstaller_3.1.5.apk')
+
md5sums=(
'26874452a6521ec2e37400670d438e33'
'7ebf618b1af94a02322d9f2d2610090b'
'5ca37e1629edb7d13b18751b72dc98ad'
'9503fc692e03d60cb8897ff2753c193f'
+ '86ffee229b724a8019cc78c5e221c24f'
+ '315362d994986e6584203fca282f4472'
'52959db8bc730ee3b7ab2cff7d41b299'
'4720f9c1a7df7cf05cbbeecdd43797e4'
'bc3143a5e334402261bf0c703db5deac'
@@ -127,6 +134,28 @@ build () {
cp -r ./$i/nodpi/priv-app/* ./squashfs-root/system/priv-app/
done
+ # install xposed
+ install -Dm 644 ./xposed.prop ./squashfs-root/system/xposed.prop
+ install -Dm 644 ./framework/XposedBridge.jar ./squashfs-root/system/framework/XposedBridge.jar
+ install -Dm 755 ./bin/app_process32_xposed ./squashfs-root/system/bin/app_process32
+ install -Dm 755 ./bin/dex2oat ./squashfs-root/system/bin/dex2oat
+ install -Dm 755 ./bin/oatdump ./squashfs-root/system/bin/oatdump
+ install -Dm 755 ./bin/patchoat ./squashfs-root/system/bin/patchoat
+ install -Dm 644 ./lib/libart.so ./squashfs-root/system/lib/libart.so
+ install -Dm 644 ./lib/libart-compiler.so ./squashfs-root/system/lib/libart-compiler.so
+ install -Dm 644 ./lib/libsigchain.so ./squashfs-root/system/lib/libsigchain.so
+ install -Dm 644 ./lib/libxposed_art.so ./squashfs-root/system/lib/libxposed_art.so
+ install -Dm 755 ./bin/app_process64_xposed ./squashfs-root/system/bin/app_process64
+ install -Dm 644 ./lib64/libart.so ./squashfs-root/system/lib64/libart.so
+ install -Dm 644 ./lib64/libart-compiler.so ./squashfs-root/system/lib64/libart-compiler.so
+ install -Dm 644 ./lib64/libart-disassembler.so ./squashfs-root/system/lib64/libart-disassembler.so
+ install -Dm 644 ./lib64/libsigchain.so ./squashfs-root/system/lib64/libsigchain.so
+ install -Dm 644 ./lib64/libxposed_art.so ./squashfs-root/system/lib64/libxposed_art.so
+
+ mkdir -p ./squashfs-root/system/app/XposedInstaller
+ chmod 755 ./squashfs-root/system/app/XposedInstaller
+ install -Dm 644 XposedInstaller_3.1.5.apk ./squashfs-root/system/app/XposedInstaller/XposedInstaller.apk
+
# install magisk
rm -f ./squashfs-root/system/bin/su
rm -f ./squashfs-root/system/xbin/su