summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJack Chen2019-10-21 12:54:59 +0800
committerJack Chen2019-10-21 12:54:59 +0800
commit3fd80764a5355975b2d5196a4571d77b8fd85588 (patch)
treeb370a4f5052cbf00d04b0dc7ed29d2489ed235c5
parent24fc1f2aabdffc1e4a52678d056b4eededb755cc (diff)
downloadaur-3fd80764a5355975b2d5196a4571d77b8fd85588.tar.gz
split rooted version to anbox-image-houdini-rooted
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD34
2 files changed, 4 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b15fd901922f..455db8f3dd5e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = anbox-image-houdini
- pkgdesc = Android image for running in Anbox with Houdini and SuperSU
+ pkgdesc = Android image for running in Anbox with Houdini
pkgver = 2018.07.19
- pkgrel = 3
+ pkgrel = 4
url = https://anbox.io/
arch = x86_64
license = custom
@@ -12,7 +12,6 @@ pkgbase = anbox-image-houdini
source = http://build.anbox.io/android-images/2018/07/19/android_amd64.img
source = houdini_y.sfs::http://dl.android-x86.org/houdini/7_y/houdini.sfs
source = houdini_z.sfs::http://dl.android-x86.org/houdini/7_z/houdini.sfs
- source = http://supersuroot.org/downloads/SuperSU-v2.82-201705271822.zip
source = media_codecs.xml
source = media_codecs_google_video.xml
source = media_codecs_google_audio.xml
@@ -20,7 +19,6 @@ pkgbase = anbox-image-houdini
md5sums = 26874452a6521ec2e37400670d438e33
md5sums = 7ebf618b1af94a02322d9f2d2610090b
md5sums = 5ca37e1629edb7d13b18751b72dc98ad
- md5sums = 8755c94775431f20bd8de368a2c7a179
md5sums = a638728bc2413d908f5eb44a9f09e947
md5sums = 599598e70060eb74c119cf7dac0ce466
md5sums = 43193761081a04ca18a28d4a6e039950
diff --git a/PKGBUILD b/PKGBUILD
index 9b502537b8e5..7515fc124a4b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname=anbox-image-houdini
pkgver=2018.07.19
-pkgrel=3
-pkgdesc='Android image for running in Anbox with Houdini and SuperSU'
+pkgrel=4
+pkgdesc='Android image for running in Anbox with Houdini'
arch=('x86_64')
url='https://anbox.io/'
license=('custom')
@@ -21,7 +21,6 @@ source=(
'http://build.anbox.io/android-images/'${pkgver//./\/}'/android_amd64.img'
'houdini_y.sfs::http://dl.android-x86.org/houdini/7_y/houdini.sfs'
'houdini_z.sfs::http://dl.android-x86.org/houdini/7_z/houdini.sfs'
- 'http://supersuroot.org/downloads/SuperSU-v2.82-201705271822.zip'
'media_codecs.xml'
'media_codecs_google_video.xml'
'media_codecs_google_audio.xml'
@@ -31,7 +30,6 @@ md5sums=(
'26874452a6521ec2e37400670d438e33'
'7ebf618b1af94a02322d9f2d2610090b'
'5ca37e1629edb7d13b18751b72dc98ad'
- '8755c94775431f20bd8de368a2c7a179'
'a638728bc2413d908f5eb44a9f09e947'
'599598e70060eb74c119cf7dac0ce466'
'43193761081a04ca18a28d4a6e039950'
@@ -102,34 +100,6 @@ build () {
# enable opengles
echo 'ro.opengles.version=131072' >> ./squashfs-root/system/build.prop
- # install supersu
- rm -f ./squashfs-root/system/bin/su
- rm -f ./squashfs-root/system/xbin/su
- rm -f ./squashfs-root/system/sbin/su
-
- mkdir -p ./squashfs-root/system/bin/.ext
- chmod 777 ./squashfs-root/system/bin/.ext
- install -Dm 755 ./x64/su ./squashfs-root/system/bin/.ext/.su
- install -Dm 755 ./x64/su ./squashfs-root/system/xbin/su
- install -Dm 755 ./x64/su ./squashfs-root/system/xbin/daemonsu
- install -Dm 755 ./x64/supolicy ./squashfs-root/system/xbin/supolicy
- install -Dm 644 ./x64/libsupol.so ./squashfs-root/system/lib64/libsupol.so
-
- mkdir -p ./squashfs-root/system/app/SuperSU
- chmod 755 ./squashfs-root/system/app/SuperSU
- install -Dm 644 ./common/Superuser.apk ./squashfs-root/system/app/SuperSU/Superuser.apk
-
- rm ./squashfs-root/system/bin/app_process
- ln -s /system/xbin/daemonsu ./squashfs-root/system/bin/app_process
- mv ./squashfs-root/system/bin/app_process64 ./squashfs-root/system/bin/app_process64_original
- ln -s /system/xbin/daemonsu ./squashfs-root/system/bin/app_process64
- cp ./squashfs-root/system/bin/app_process64_original ./squashfs-root/system/bin/app_process_init
-
- chmod +w ./squashfs-root/system/etc/init.goldfish.sh
- echo '/system/xbin/daemonsu --auto-daemon &' >> ./squashfs-root/system/etc/init.goldfish.sh
- chmod -w ./squashfs-root/system/etc/init.goldfish.sh
- echo 1 > ./squashfs-root/system/etc/.installed_su_daemon
-
# install media codecs
cp media_codec*.xml ./squashfs-root/system/etc/
}