summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsickcodes2021-12-13 01:10:35 +0000
committersickcodes2021-12-13 01:10:35 +0000
commit20a63e6c219e218edc49731cc21c2b3db1336e0b (patch)
tree7b953bbce351ed6c0631be77cee4f08e165b2663
parent724a630cc803142151f789affc67c80a068699f5 (diff)
downloadaur-20a63e6c219e218edc49731cc21c2b3db1336e0b.tar.gz
Update to https://github.com/sickcodes/aur/commit/5e900cd21fc4d6729bb9d41f0bbc47f060cfd06c
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD26
2 files changed, 12 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 099aecfce82d..2fafe43df795 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,10 +8,11 @@ pkgbase = anbox-modules-dkms
arch = i386
license = GPL3
makedepends = git
- depends = linux-headers
depends = dkms
provides = anbox-modules-dkms
- source = anbox-modules::git+https://github.com/choff/anbox-modules.git#branch=master
+ source = git+https://github.com/choff/anbox-modules.git#branch=master
+ source = https://github.com/sickcodes/anbox-modules/commit/7c19d3c66758747d854c63e4c34ef127ce201fa6.patch
sha256sums = SKIP
+ sha256sums = 7589f311fd9a503c30a214b54f1f687c26a2f160d4339098c65f655e9b1e3556
pkgname = anbox-modules-dkms
diff --git a/PKGBUILD b/PKGBUILD
index a3287a2f8ad3..f1aee57fffad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,42 +12,34 @@ pkgdesc='Android kernel driver fork by @choff (binder/binderfs & ashmem) in DKMS
arch=('x86_64' 'aarch64' 'i386')
license=('GPL3')
provides=("${pkgname}")
-depends=('linux-headers' 'dkms')
+depends=('dkms')
makedepends=('git')
-source=("${_pkgname}::git+https://github.com/choff/${_pkgname}.git#branch=master")
-sha256sums=('SKIP')
+source=("git+https://github.com/choff/${_pkgname}.git#branch=master"
+ "https://github.com/sickcodes/anbox-modules/commit/7c19d3c66758747d854c63e4c34ef127ce201fa6.patch")
+sha256sums=('SKIP'
+ '7589f311fd9a503c30a214b54f1f687c26a2f160d4339098c65f655e9b1e3556')
prepare() {
cd "${srcdir}/${_pkgname}"
-}
-
-build() {
-
- cd "${srcdir}/${_pkgname}/binder"
- make
- cd "${srcdir}/${_pkgname}/ashmem"
- make
+ # Patch for 5.10-lts
+ patch -p1 -i "${srcdir}"/7c19d3c66758747d854c63e4c34ef127ce201fa6.patch
}
package() {
- install -dm755 "$pkgdir/usr/bin"
- # install -dm755 "${pkgdir}/usr/lib/modules/${_arch}"
- install -dm755 "${pkgdir}/usr/lib/modules-load.d"
install -dm755 "${pkgdir}/usr/src/binder-1"
install -dm755 "${pkgdir}/usr/src/ashmem-1"
cp -r "${srcdir}/${_pkgname}/binder/"* "${pkgdir}/usr/src/binder-1/"
cp -r "${srcdir}/${_pkgname}/ashmem/"* "${pkgdir}/usr/src/ashmem-1/"
- install -Dm644 "${srcdir}/${_pkgname}/binder/dkms.conf" "${pkgdir}/usr/lib/modules-load.d/binder.conf"
- install -Dm644 "${srcdir}/${_pkgname}/ashmem/dkms.conf" "${pkgdir}/usr/lib/modules-load.d/ashmem.conf"
-
cd "${srcdir}/${_pkgname}/binder"
+ make
make DESTDIR="${pkgdir}/usr/src/binder-1" install
cd "${srcdir}/${_pkgname}/ashmem"
+ make
make DESTDIR="${pkgdir}/usr/src/ashmem-1" install
echo '** To activate binder_linux and ashmem_linux **