summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsickcodes2021-12-17 05:28:26 +0000
committersickcodes2021-12-17 05:28:26 +0000
commitd77ac721b2e845eb537f23f936287f8b6bbb0363 (patch)
treec383476bb46690392473d134913c47021ddf804b
parent20a63e6c219e218edc49731cc21c2b3db1336e0b (diff)
downloadaur-d77ac721b2e845eb537f23f936287f8b6bbb0363.tar.gz
Update to https://github.com/sickcodes/aur/commit/dffca947ee02be66fe4ea54682a6d5ae1195b798
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2fafe43df795..dfb5e20b6f8a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = anbox-modules-dkms
pkgdesc = Android kernel driver fork by @choff (binder/binderfs & ashmem) in DKMS format
- pkgver = 5
- pkgrel = 15
+ pkgver = r38.8148a16
+ pkgrel = 1
url = https://github.com/choff/anbox-modules
arch = x86_64
arch = aarch64
@@ -10,7 +10,7 @@ pkgbase = anbox-modules-dkms
makedepends = git
depends = dkms
provides = anbox-modules-dkms
- source = git+https://github.com/choff/anbox-modules.git#branch=master
+ source = git+https://github.com/choff/anbox-modules.git#commit=8148a162755bf5500a07cf41a65a02c8f3eb0af9
source = https://github.com/sickcodes/anbox-modules/commit/7c19d3c66758747d854c63e4c34ef127ce201fa6.patch
sha256sums = SKIP
sha256sums = 7589f311fd9a503c30a214b54f1f687c26a2f160d4339098c65f655e9b1e3556
diff --git a/PKGBUILD b/PKGBUILD
index f1aee57fffad..b91064bf038a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,21 +4,26 @@
pkgname=anbox-modules-dkms
_pkgname=anbox-modules
-pkgver=5
+pkgver=r38.8148a16
arch="$(uname -r)"
url='https://github.com/choff/anbox-modules'
-pkgrel=15
+pkgrel=1
pkgdesc='Android kernel driver fork by @choff (binder/binderfs & ashmem) in DKMS format'
arch=('x86_64' 'aarch64' 'i386')
license=('GPL3')
provides=("${pkgname}")
depends=('dkms')
makedepends=('git')
-source=("git+https://github.com/choff/${_pkgname}.git#branch=master"
+source=("git+https://github.com/choff/${_pkgname}.git#commit=8148a162755bf5500a07cf41a65a02c8f3eb0af9"
"https://github.com/sickcodes/anbox-modules/commit/7c19d3c66758747d854c63e4c34ef127ce201fa6.patch")
sha256sums=('SKIP'
'7589f311fd9a503c30a214b54f1f687c26a2f160d4339098c65f655e9b1e3556')
+pkgver() {
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
prepare() {
cd "${srcdir}/${_pkgname}"