summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSte742015-10-12 19:05:14 +0200
committerSte742015-10-12 19:05:14 +0200
commit28a7a4b85de98383cc52a7e4af963bd43fc47e58 (patch)
treebbe3b04dac0f7cadb92b4737ac14911d5de53932
downloadaur-28a7a4b85de98383cc52a7e4af963bd43fc47e58.tar.gz
Initial import
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD61
-rw-r--r--ancestris.desktop9
-rw-r--r--ancestris.install35
-rw-r--r--ancestris.pngbin0 -> 2679 bytes
5 files changed, 133 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6b217201cb05
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+# Generated by mksrcinfo v7
+# Mon Oct 12 17:04:46 UTC 2015
+pkgbase = ancestris
+ pkgdesc = Ancestris is a genealogy program written in Java
+ pkgver = 0.8
+ pkgrel = 1
+ url = http://ancestris.org/
+ install = ancestris.install
+ arch = any
+ license = CDDL
+ license = GPL
+ depends = java-environment
+ depends = ttf-font
+ depends = libxtst
+ depends = giflib
+ depends = atk
+ provides = ancestris
+ source = http://www.ancestris.org/mw/mw-base/compteur_dl.php?/dl/pub/ancestris/releases/ancestris_0.8-0-20150521.zip
+ source = ancestris.install
+ source = ancestris.desktop
+ source = ancestris.png
+ md5sums = 4307e7badb913ae304793043a791230a
+ md5sums = 4252d135a228c77f49a651225c037e07
+ md5sums = 2d23096eea04659d55dc6d45fb57cc37
+ md5sums = bae346ed409e57d174386cd7db583ff5
+
+pkgname = ancestris
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..722c1f62d8bc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# Maintainer : lemovice <lemovice-at-ancestris-dot-org>
+# Contributor :
+
+pkgname=ancestris
+pkgver=0.8
+pkgrel=1
+pkgdesc='Ancestris is a genealogy program written in Java'
+arch=('any')
+url='http://ancestris.org/'
+license=('CDDL' 'GPL')
+provides=('ancestris')
+
+depends=('java-environment' 'ttf-font' 'libxtst' 'giflib' 'atk')
+install='ancestris.install'
+#options=('!strip')
+source=('http://www.ancestris.org/mw/mw-base/compteur_dl.php?/dl/pub/ancestris/releases/ancestris_0.8-0-20150521.zip'
+'ancestris.install'
+'ancestris.desktop'
+'ancestris.png')
+md5sums=('4307e7badb913ae304793043a791230a'
+ '4252d135a228c77f49a651225c037e07'
+ '2d23096eea04659d55dc6d45fb57cc37'
+ 'bae346ed409e57d174386cd7db583ff5')
+DLAGENTS=('ftp::/usr/bin/curl -fC - --ftp-pasv --retry 3 --retry-delay 3 -o %o %u'
+ 'http::/usr/bin/curl -A "Mozilla/4.0" -fLC - --retry 3 --retry-delay 3 -o %o %u'
+ 'https::/usr/bin/curl -A "Mozilla/4.0" -fLC - --retry 3 --retry-delay 3 -o %o %u'
+ 'rsync::/usr/bin/rsync --no-motd -z %u %o'
+ 'scp::/usr/bin/scp -C %u %o')
+
+
+build() {
+ # cleanup OS specific files
+ rm $(find -name '*\.exe' -or -name '*\.bat')
+# rm -r $(find -name 'MacOSX*' -or -name 'Windows*' -or -name 'SunOS*')
+# rm -r $(find -name 'hpux*' -or -name 'mac*' -or -name 'solaris*' -or -name 'windows*')
+ # Remove 64 bits files on an i686 system else stripping fails
+ if [ `uname -m` = 'i686' ]; then
+ rm -rf $(find -name '*64*')
+ rm -rf $(find -name '*x64*')
+ rm -rf $(find -name 'Linux-x86_64')
+ fi
+ if [ `uname -m` = 'x86_64' ]; then
+ rm -rf $(find -name '*86*')
+ fi
+}
+
+package() {
+ install -d ${pkgdir}/usr/share/java
+ cp -r ${pkgname} ${pkgdir}/usr/share/java
+
+ install -d ${pkgdir}/usr/bin
+ ln -s /usr/share/java/${pkgname}/bin/${pkgname} ${pkgdir}/usr/bin/${pkgname}
+
+ install -d ${pkgdir}/usr/share/applications
+ install -m644 /$srcdir/${pkgname}.desktop ${pkgdir}/usr/share/applications
+
+ install -d ${pkgdir}/usr/share/pixmaps
+ install -m644 $srcdir/${pkgname}.png ${pkgdir}/usr/share/pixmaps
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/ancestris.desktop b/ancestris.desktop
new file mode 100644
index 000000000000..485994fb0aff
--- /dev/null
+++ b/ancestris.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Ancestris
+Comment=Ancestris
+Icon=ancestris
+Exec=ancestris
+Terminal=false
+Type=Application
+Categories=Office;
+StartupNotify=true
diff --git a/ancestris.install b/ancestris.install
new file mode 100644
index 000000000000..e986c260b89f
--- /dev/null
+++ b/ancestris.install
@@ -0,0 +1,35 @@
+# This is a default template for a post-install scriptlet. You can
+# remove any functions you don't need (and this header).
+
+# arg 1: the new package version
+pre_install() {
+ /bin/true
+}
+
+# arg 1: the new package version
+post_install() {
+ update-desktop-database >/dev/null 2>&1
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+pre_upgrade() {
+ /bin/true
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ update-desktop-database >/dev/null 2>&1
+}
+
+# arg 1: the old package version
+pre_remove() {
+ /bin/true
+}
+
+# arg 1: the old package version
+post_remove() {
+ update-desktop-database >/dev/null 2>&1
+}
+
diff --git a/ancestris.png b/ancestris.png
new file mode 100644
index 000000000000..2be0e280aa12
--- /dev/null
+++ b/ancestris.png
Binary files differ