summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXavion2018-12-25 11:41:55 +1100
committerXavion2018-12-25 11:41:55 +1100
commita6c6cf4738649aba4251f3e5ce60ec95353a0217 (patch)
tree72c545cb0aca6edd0255eb4365720c9135dd88ef
downloadaur-a6c6cf4738649aba4251f3e5ce60ec95353a0217.tar.gz
Initial release (0.1.0-1)
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD21
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a2744c58ee96
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = ancient-packages
+ pkgdesc = Lists installed packages no longer available (anywhere)
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = http://public.files.xavion.name/Software/ancient-packages/ancient-packages.jpg
+ arch = any
+ license = GPL3
+ depends = package-query
+ options = !emptydirs
+ source = http://public.files.xavion.name/Software/ancient-packages/ancient-packages
+ sha1sums = ec4d31d3dba2ac98019bf2557a6e9e9fcfa822c2
+
+pkgname = ancient-packages
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bfeba6860040
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Xavion <Xavion (dot) 0 (at) Gmail (dot) com>
+
+pkgname=ancient-packages
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Lists installed packages no longer available (anywhere)"
+url="http://public.files.xavion.name/Software/${pkgname}/${pkgname}.jpg"
+arch=("any")
+license=("GPL3")
+depends=("package-query")
+#optdepends=("pacman-cage: Better performance")
+options=(!emptydirs)
+source=(http://public.files.xavion.name/Software/${pkgname}/${pkgname})
+
+package() {
+ cd "${srcdir}"
+
+ install -D -m755 ${pkgname} "${pkgdir}"/usr/bin/${pkgname}
+}
+
+sha1sums=('ec4d31d3dba2ac98019bf2557a6e9e9fcfa822c2')