summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonzalo Exequiel Pedone2019-04-05 11:04:39 -0300
committerGonzalo Exequiel Pedone2019-04-05 11:04:39 -0300
commit3a60b69fdec74243de7447a64fdb4ab193380cbf (patch)
treeb9d04fa60f7e0d5ace1ace3080dc32dbdb0548d3
parent421f2b4cbda80d897dad62fefb49f67abebdbf70 (diff)
downloadaur-3a60b69fdec74243de7447a64fdb4ab193380cbf.tar.gz
Package updated.
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD18
-rwxr-xr-xandroid-env.sh25
4 files changed, 40 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3957e00d9e9a..7d6a5f5f354d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,16 @@
# Generated by mksrcinfo v8
-# jue abr 4 20:54:16 UTC 2019
+# vie abr 5 14:04:00 UTC 2019
pkgbase = android-aarch64-ffmpeg
pkgdesc = Complete solution to record, convert and stream audio and video (android)
pkgver = 4.1.2
- pkgrel = 2
+ pkgrel = 3
url = http://ffmpeg.org/
arch = any
license = GPL3
makedepends = android-pkg-config
makedepends = git
makedepends = yasm
- depends = apache-ant
- depends = android-ndk>=r18.b
- depends = android-platform-22
- depends = android-sdk-25.2.5
- depends = android-sdk-build-tools
- depends = android-sdk-platform-tools
+ depends = android-aarch64-libvorbis
options = !strip
options = !buildflags
options = staticlibs
diff --git a/.gitignore b/.gitignore
index b5bc2aa573e1..78bc5ca47508 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@ pkg
src
*.tar.xz
*.tar.gz
+ffmpeg
diff --git a/PKGBUILD b/PKGBUILD
index 95e00a12f2cc..1b78e7bb5a5a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,17 +6,12 @@ source android-env.sh ${_android_arch}
pkgname=android-${_android_arch}-ffmpeg
pkgver=4.1.2
-pkgrel=2
+pkgrel=3
pkgdesc="Complete solution to record, convert and stream audio and video (android)"
arch=('any')
url="http://ffmpeg.org/"
license=('GPL3')
-depends=('apache-ant'
- 'android-ndk>=r18.b'
- "android-platform-$ANDROID_MINIMUM_PLATFORM"
- 'android-sdk-25.2.5'
- 'android-sdk-build-tools'
- 'android-sdk-platform-tools')
+depends=("android-${_android_arch}-libvorbis")
options=(!strip !buildflags staticlibs !emptydirs)
makedepends=('android-pkg-config' 'git' 'yasm')
source=("git+https://git.ffmpeg.org/ffmpeg.git#tag=n${pkgver}"
@@ -94,6 +89,15 @@ build() {
;;
esac
+ case "$_android_arch" in
+ aarch64)
+ ;;
+ *)
+ configue_opts+="
+ --enable-libvorbis"
+ ;;
+ esac
+
./configure ${configue_opts}
make $MAKEFLAGS
}
diff --git a/android-env.sh b/android-env.sh
index d9f6b78ecbb9..f967d7dcd35c 100755
--- a/android-env.sh
+++ b/android-env.sh
@@ -6,6 +6,10 @@
_android_arch=$1
+if [ -z "${_android_arch}" ]; then
+ _android_arch=armv7a-eabi
+fi
+
# Minimum Android platform based on:
#
# https://developer.android.com/about/dashboards/
@@ -71,3 +75,24 @@ export ANDROID_STRIP=${ANDROID_TOOLS_PREFIX}strip
export ANDROID_LIBS=/opt/android-libs/${_android_arch}
export PKG_CONFIG_SYSROOT_DIR=${ANDROID_LIBS}
export PKG_CONFIG_LIBDIR=${PKG_CONFIG_SYSROOT_DIR}/lib/pkgconfig:${PKG_CONFIG_SYSROOT_DIR}/share/pkgconfig
+
+ndk_version() {
+ grep 'Pkg.Revision' ${ANDROID_NDK_ROOT}/source.properties | awk '{print $3}'
+}
+
+ndk_version_ge_than() {
+ version=$1
+ ndk_ver=$(ndk_version)
+
+ if [ "${version}" = "${ndk_ver}" ]; then
+ return 0
+ fi
+
+ older_ver=$(printf "${version}\n${ndk_ver}" | sort -V | head -n 1)
+
+ if [ "${older_ver}" = "${ndk_ver}" ]; then
+ return 1
+ fi
+
+ return 0
+}