diff options
author | Gonzalo Exequiel Pedone | 2020-01-18 18:10:11 -0300 |
---|---|---|
committer | Gonzalo Exequiel Pedone | 2020-01-18 18:10:11 -0300 |
commit | c7ff42b58919673dc474b853bdf6afcf95079173 (patch) | |
tree | 6ffeafd601477d5a3a02e9eeef8ddb22045133e6 | |
parent | 5d03626f121dbba7cf3bbc597b3255624ab6ad15 (diff) | |
download | aur-c7ff42b58919673dc474b853bdf6afcf95079173.tar.gz |
Added libssh support.
-rw-r--r-- | .SRCINFO | 3 | ||||
-rw-r--r-- | PKGBUILD | 6 |
2 files changed, 6 insertions, 3 deletions
@@ -1,7 +1,7 @@ pkgbase = android-aarch64-ffmpeg pkgdesc = Complete solution to record, convert and stream audio and video (android) pkgver = 4.2.2 - pkgrel = 1 + pkgrel = 2 url = http://ffmpeg.org/ arch = any license = GPL3 @@ -10,6 +10,7 @@ pkgbase = android-aarch64-ffmpeg makedepends = yasm depends = android-aarch64-bzip2 depends = android-aarch64-lame + depends = android-aarch64-libssh depends = android-aarch64-libtheora depends = android-aarch64-libvorbis depends = android-aarch64-libvpx @@ -4,13 +4,14 @@ _android_arch=aarch64 pkgname=android-${_android_arch}-ffmpeg pkgver=4.2.2 -pkgrel=1 +pkgrel=2 pkgdesc="Complete solution to record, convert and stream audio and video (android)" arch=('any') url="http://ffmpeg.org/" license=('GPL3') depends=("android-${_android_arch}-bzip2" "android-${_android_arch}-lame" + "android-${_android_arch}-libssh" "android-${_android_arch}-libtheora" "android-${_android_arch}-libvorbis" "android-${_android_arch}-libvpx" @@ -48,7 +49,7 @@ build() { case "$_android_arch" in aarch64) target_arch=aarch64 - export LDFLAGS="-L${ANDROID_PREFIX_LIB} -lm -logg -lvorbis" + export LDFLAGS="-L${ANDROID_PREFIX_LIB} -lm -logg -lvorbis -lssh -lcrypto_1_1 -lssl_1_1" ;; armv7a-eabi) target_arch=arm @@ -95,6 +96,7 @@ build() { --enable-libmp3lame --enable-libopus --enable-libspeex + --enable-libssh --enable-libtheora --enable-libvorbis --enable-libvpx |