summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonzalo Exequiel Pedone2019-03-12 23:28:54 -0300
committerGonzalo Exequiel Pedone2019-03-12 23:28:54 -0300
commitd1c9c0945ea3acf754ff07f3287681f495abf73f (patch)
treee300cba9904eedd0882a898f9607b6e3304b3b33
parent4666d9b8f281e2f2cc03fdeec341174b14f077ed (diff)
downloadaur-d1c9c0945ea3acf754ff07f3287681f495abf73f.tar.gz
Package updated.
-rw-r--r--.SRCINFO15
-rw-r--r--0003-Fix-androiddeployqt-search-paths.patch29
-rw-r--r--PKGBUILD44
-rw-r--r--android-aarch64-qt5.install9
4 files changed, 36 insertions, 61 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aefc14253ac7..b06129ba09df 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
# Generated by mksrcinfo v8
-# lun feb 18 21:48:27 UTC 2019
+# miƩ mar 13 02:26:13 UTC 2019
pkgbase = android-aarch64-qt5
pkgdesc = Qt 5 for Android
pkgver = 5.12.1
- pkgrel = 2
+ pkgrel = 3
url = https://www.qt.io
+ install = android-aarch64-qt5.install
arch = x86_64
groups = android-qt5
license = GPL3
@@ -17,15 +18,15 @@ pkgbase = android-aarch64-qt5
makedepends = gperf
makedepends = libxslt
makedepends = fontconfig
- depends = jre-openjdk-headless
+ depends = java-runtime-headless-openjdk<=8
depends = apache-ant
depends = android-ndk>=r18.b
depends = android-platform-22
- depends = android-sdk
+ depends = android-sdk<=25.2.5
depends = android-sdk-build-tools
depends = android-sdk-platform-tools
- optdepends = android-google-apis-armv7a-eabi: AVD support
- optdepends = android-armv7a-eabi-system-image: AVD support
+ optdepends = android-google-apis-arm64-v8a: AVD support
+ optdepends = android-arm64-v8a-system-image: AVD support
options = !strip
options = !buildflags
options = staticlibs
@@ -33,11 +34,9 @@ pkgbase = android-aarch64-qt5
source = http://download.qt-project.org/official_releases/qt/5.12/5.12.1/single/qt-everywhere-src-5.12.1.tar.xz
source = 0001-Fix-clang-build.patch
source = 0002-Disable-mapbox.patch
- source = 0003-Fix-androiddeployqt-search-paths.patch
md5sums = 6a37466c8c40e87d4a19c3f286ec2542
md5sums = bf97665c96c0a084ea7970eb61556754
md5sums = 20d8bdd24102e9011b561b7361394728
- md5sums = 90141a931baac77fa608146f32414ead
pkgname = android-aarch64-qt5
diff --git a/0003-Fix-androiddeployqt-search-paths.patch b/0003-Fix-androiddeployqt-search-paths.patch
deleted file mode 100644
index 8a49d0704229..000000000000
--- a/0003-Fix-androiddeployqt-search-paths.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- a/qtbase/src/tools/androiddeployqt/main.cpp 2018-12-03 08:15:26.000000000 -0300
-+++ b/qtbase/src/tools/androiddeployqt/main.cpp 2018-12-11 13:52:56.700766773 -0300
-@@ -1663,7 +1663,7 @@
- rootPath += QLatin1Char('/');
-
- QStringList importPaths;
-- importPaths += shellQuote(options->qtInstallDirectory + QLatin1String("/qml"));
-+ importPaths += shellQuote(options->qtInstallDirectory + QLatin1String("/lib/qt/qml"));
- importPaths += rootPath;
- for (const QString &qmlImportPath : qAsConst(options->qmlImportPaths))
- importPaths += shellQuote(qmlImportPath);
-@@ -1758,7 +1758,7 @@
- fprintf(stdout, " -- Appending dependency found by qmlimportscanner: %s\n", qPrintable(fileName.absolutePath));
-
- // Put all imports in default import path in assets
-- fileName.relativePath.prepend(QLatin1String("qml/"));
-+ fileName.relativePath.prepend(QLatin1String("lib/qt/qml/"));
- options->qtDependencies.append(fileName);
-
- if (fileName.absolutePath.endsWith(QLatin1String(".so"))) {
-@@ -1794,7 +1794,7 @@
- return false;
-
- // Jam in the dependencies of the platform plugin, since the application will crash without it
-- if (!readDependenciesFromElf(options, options->qtInstallDirectory + QLatin1String("/plugins/platforms/android/libqtforandroid.so"), &usedDependencies, &remainingDependencies))
-+ if (!readDependenciesFromElf(options, options->qtInstallDirectory + QLatin1String("/lib/qt/plugins/platforms/android/libqtforandroid.so"), &usedDependencies, &remainingDependencies))
- return false;
-
- while (!remainingDependencies.isEmpty()) {
diff --git a/PKGBUILD b/PKGBUILD
index c91b319a9d05..9bad2b692737 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -28,7 +28,7 @@ fi
pkgname=android-${_android_arch}-qt5
pkgver=5.12.1
-pkgrel=2
+pkgrel=3
pkgdesc="Qt 5 for Android"
arch=('x86_64')
url='https://www.qt.io'
@@ -41,31 +41,31 @@ makedepends=('libgl'
'gperf'
'libxslt'
'fontconfig')
-depends=('jre-openjdk-headless'
+depends=('java-runtime-headless-openjdk<=8'
'apache-ant'
'android-ndk>=r18.b'
"android-platform-$ANDROID_MINIMUM_PLATFORM"
- 'android-sdk'
+ 'android-sdk<=25.2.5'
'android-sdk-build-tools'
'android-sdk-platform-tools')
groups=('android-qt5')
case "$_android_arch" in
aarch64)
- optdepends=('android-google-apis-armv7a-eabi: AVD support'
- 'android-armv7a-eabi-system-image: AVD support')
+ optdepends=("android-google-apis-arm64-v8a: AVD support"
+ "android-arm64-v8a-system-image: AVD support")
;;
armv7a-eabi)
- optdepends=('android-google-apis-armv7a-eabi: AVD support'
- 'android-armv7a-eabi-system-image: AVD support')
+ optdepends=("android-google-apis-armv7a-eabi: AVD support"
+ "android-armv7a-eabi-system-image: AVD support")
;;
x86)
- optdepends=('android-google-apis-x86: AVD support'
- 'android-x86-system-image: AVD support')
+ optdepends=("android-google-apis-x86: AVD support"
+ "android-x86-system-image: AVD support")
;;
x86-64)
- optdepends=('android-google-apis-x86-64: AVD support'
- 'android-x86-64-system-image: AVD support')
+ optdepends=("android-google-apis-x86-64: AVD support"
+ "android-x86-64-system-image: AVD support")
;;
*)
;;
@@ -76,14 +76,13 @@ options=('!strip'
'staticlibs'
'!emptydirs')
_pkgfqn="qt-everywhere-src-${pkgver}"
+install="${pkgname}.install"
source=("http://download.qt-project.org/official_releases/qt/${pkgver:0:4}/${pkgver}/single/${_pkgfqn}.tar.xz"
"0001-Fix-clang-build.patch"
- "0002-Disable-mapbox.patch"
- "0003-Fix-androiddeployqt-search-paths.patch")
+ "0002-Disable-mapbox.patch")
md5sums=('6a37466c8c40e87d4a19c3f286ec2542'
'bf97665c96c0a084ea7970eb61556754'
- '20d8bdd24102e9011b561b7361394728'
- '90141a931baac77fa608146f32414ead')
+ '20d8bdd24102e9011b561b7361394728')
_pref=/opt/android-libs/$_android_arch
@@ -91,9 +90,9 @@ prepare() {
cd ${_pkgfqn}
# Platform specific patches.
+
patch -Np1 -i "../0001-Fix-clang-build.patch"
patch -Np1 -i "../0002-Disable-mapbox.patch"
- patch -Np1 -i "../0003-Fix-androiddeployqt-search-paths.patch"
sed -i "s/android-16/android-$ANDROID_MINIMUM_PLATFORM/g" qtbase/mkspecs/features/android/sdk.prf
sed -i "s/android-16/android-$ANDROID_MINIMUM_PLATFORM/g" qtbase/src/android/jar/jar.pro
sed -i "s/android-16/android-$ANDROID_MINIMUM_PLATFORM/g" qtgamepad/src/plugins/gamepads/android/jar/jar.pro
@@ -151,10 +150,8 @@ build() {
-opensource
-silent
-prefix ${_pref}
- -archdatadir ${_pref}/lib/qt
- -datadir ${_pref}/share/qt
- -examplesdir ${_pref}/share/qt/examples
- -testsdir ${_pref}/share/qt/tests
+ -examplesdir ${_pref}/share/qt5/examples
+ -testsdir ${_pref}/share/qt5/tests
-xplatform android-clang
-nomake tests
-nomake examples
@@ -187,7 +184,6 @@ build() {
esac
./configure ${configue_opts}
-
make $MAKEFLAGS
}
@@ -218,8 +214,8 @@ package() {
STRIP=${ANDROID_NDK_ROOT}/toolchains/${toolchain}/prebuilt/linux-x86_64/${stripFolder}/bin/strip
find ${pkgdir}/${_pref}/bin -type f ! -name '*.pl' -exec strip {} \;
find ${pkgdir}/${_pref}/lib -type f -name 'lib*.so' -exec ${STRIP} {} \;
- find ${pkgdir}/${_pref}/lib -type f \( -name 'lib*.a' ! -name 'libQt5Bootstrap.a' ! -name 'libQt5QmlDevTools.a' \) -exec ${STRIP} {} \;
- find ${pkgdir}/${_pref}/lib/qt/plugins -type f -name 'lib*.so' -exec ${STRIP} {} \;
+ # find ${pkgdir}/${_pref}/lib -type f \( -name 'lib*.a' ! -name 'libQt5Bootstrap.a' ! -name 'libQt5QmlDevTools.a' \) -exec ${STRIP} {} \;
+ find ${pkgdir}/${_pref}/plugins -type f -name 'lib*.so' -exec ${STRIP} {} \;
+ find ${pkgdir}/${_pref}/qml -type f -name 'lib*.so' -exec ${STRIP} {} \;
sed -i '/QMAKE_PRL_BUILD_DIR/d' ${pkgdir}/${_pref}/lib/lib*.prl
- sed -i 's/\"plugins\//\"lib\/qt\/plugins\//g' ${pkgdir}/${_pref}/lib/*-android-dependencies.xml
}
diff --git a/android-aarch64-qt5.install b/android-aarch64-qt5.install
new file mode 100644
index 000000000000..2e3a6d0ad722
--- /dev/null
+++ b/android-aarch64-qt5.install
@@ -0,0 +1,9 @@
+post_install() {
+ cat << EOF
+
+Qt for Android only support up to Java 8, set it as default with:
+
+sudo archlinux-java set java-8-openjdk
+
+EOF
+}