summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2021-01-05 01:29:15 +0100
committerMartchus2021-01-05 01:29:15 +0100
commitc9e3cd94c8c46ebed1504d79a9c667367fcbd5c7 (patch)
treead5dd8bf7bd6e62b31f4540fb6c35aaf34c1e71e
downloadaur-c9e3cd94c8c46ebed1504d79a9c667367fcbd5c7.tar.gz
Initial import; Qt 6.0.0
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD51
-rw-r--r--PKGBUILD.sh.ep11
-rw-r--r--qt5compat-sha256.txt1
4 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bfd2d4a78a27
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = android-aarch64-qt6-5compat
+ pkgdesc = Module that contains unsupported Qt 5 APIs (android)
+ pkgver = 6.0.0
+ pkgrel = 1
+ url = https://www.qt.io
+ arch = any
+ groups = android-aarch64-qt6
+ license = GPL3
+ license = LGPL3
+ license = FDL
+ license = custom
+ makedepends = android-cmake
+ makedepends = qt6-base
+ makedepends = ninja
+ makedepends = java-environment-openjdk=8
+ depends = android-aarch64-qt6-base
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ options = !emptydirs
+ source = https://download.qt.io/official_releases/qt/6.0/6.0.0/submodules/qt5compat-everywhere-src-6.0.0.tar.xz
+ sha256sums = 13b9d78aa698609d07376e3e9e9d1a82a96084236aba0642f8ac695c181ab25f
+
+pkgname = android-aarch64-qt6-5compat
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1db96cb0d1ed
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Martchus <martchus@gmx.net>
+
+# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
+# you also find the URL of a binary repository.
+
+_android_arch=aarch64
+pkgname=android-$_android_arch-qt6-5compat
+_qtver=6.0.0
+pkgver=${_qtver/-/}
+pkgrel=1
+arch=(any)
+url='https://www.qt.io'
+license=(GPL3 LGPL3 FDL custom)
+pkgdesc='Module that contains unsupported Qt 5 APIs (android)'
+depends=('android-aarch64-qt6-base')
+makedepends=('android-cmake' 'qt6-base' 'ninja' 'java-environment-openjdk=8')
+options=('!strip' '!buildflags' 'staticlibs' '!emptydirs')
+groups=(android-${_android_arch}-qt6)
+_pkgfqn="qt5compat-everywhere-src-${_qtver}"
+source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz")
+sha256sums=('13b9d78aa698609d07376e3e9e9d1a82a96084236aba0642f8ac695c181ab25f')
+
+build() {
+ source android-env ${_android_arch}
+ android-${_android_arch}-cmake -G Ninja -B build-$_android_arch -S $_pkgfqn \
+ -DCMAKE_FIND_ROOT_PATH="${ANDROID_PREFIX}" \
+ -DQT_BINARY_DIR=${ANDROID_PREFIX_BIN} \
+ -DQT_INCLUDE_DIRS_NO_SYSTEM=ON \
+ -DQT_HOST_PATH=/usr \
+ -DANDROID_SDK_ROOT=${ANDROID_HOME} \
+ -DANDROID_NDK_ROOT=${ANDROID_NDK_HOME} \
+ -DANDROID_STL="c++_shared" \
+ -DFEATURE_pkg_config=ON
+ cmake --build build-$_android_arch
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build-$_android_arch
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "$pkgdir/${ANDROID_PREFIX}" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+
+ find ${pkgdir}/${ANDROID_PREFIX} -type f -name 'lib*.so' -exec ${ANDROID_STRIP} -g --strip-unneeded {} \;
+ find ${pkgdir}/${ANDROID_PREFIX} -type f -name 'lib*.a' -exec ${ANDROID_STRIP} -g {} \;
+ [[ -d "${pkgdir}/${ANDROID_PREFIX}/share/doc" ]] && rm -r "${pkgdir}/${ANDROID_PREFIX}/share/doc" || true
+
+ install -d "$pkgdir"/usr/share/licenses
+ ln -s /usr/share/licenses/android-$_android_arch-qt6-base "$pkgdir"/usr/share/licenses/$pkgname
+
+}
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
new file mode 100644
index 000000000000..1905158297ec
--- /dev/null
+++ b/PKGBUILD.sh.ep
@@ -0,0 +1,11 @@
+% layout 'android-qt6-module';
+\
+_qtver=6.0.0
+pkgver=${_qtver/-/}
+pkgrel=1
+arch=(any)
+url='https://www.qt.io'
+license=(GPL3 LGPL3 FDL custom)
+pkgdesc='Module that contains unsupported Qt 5 APIs (android)'
+depends=(<%== qt6deps qw(base) %>)
+makedepends=('android-cmake<%== $static_suffix %>' 'qt6-base' 'ninja' 'java-environment-openjdk=8')
diff --git a/qt5compat-sha256.txt b/qt5compat-sha256.txt
new file mode 100644
index 000000000000..eb3f9b200340
--- /dev/null
+++ b/qt5compat-sha256.txt
@@ -0,0 +1 @@
+13b9d78aa698609d07376e3e9e9d1a82a96084236aba0642f8ac695c181ab25f