summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2023-09-18 21:57:07 +0200
committerMartchus2023-09-18 21:57:07 +0200
commit1ac8729fbc96ea01e115056fcfdde8ba04d511cd (patch)
tree532928abcfbf91f513bf69ccd460fe55da6723d2
parent73e6f6b8d6e2db4281250dca0fe08ab0969f8912 (diff)
downloadaur-1ac8729fbc96ea01e115056fcfdde8ba04d511cd.tar.gz
Fix build
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD4
-rw-r--r--PKGBUILD.sh.ep4
-rw-r--r--qtlocation-sha256.txt1
4 files changed, 13 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b1089fa79c86..b854d9ae7b30 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,6 +9,13 @@ pkgbase = android-aarch64-qt6-location
license = LGPL3
license = FDL
license = custom
+ makedepends = android-cmake
+ makedepends = android-aarch64-qt6-shadertools
+ makedepends = android-aarch64-qt6-declarative
+ makedepends = qt6-shadertools
+ makedepends = qt6-declarative
+ makedepends = ninja
+ makedepends = java-environment-openjdk>=11
depends = android-aarch64-qt6-declarative
depends = android-aarch64-qt6-positioning
options = !strip
@@ -16,7 +23,6 @@ pkgbase = android-aarch64-qt6-location
options = staticlibs
options = !emptydirs
source = https://download.qt.io/official_releases/qt/6.5/6.5.2/submodules/qtlocation-everywhere-src-6.5.2.tar.xz
- sha256sums = qtlocation-sha256.txt missing
+ sha256sums = 891d7d64c26617bf1993a6d8b3d206ec9ce5b0a5396146f691b11d895fd86dfb
pkgname = android-aarch64-qt6-location
-
diff --git a/PKGBUILD b/PKGBUILD
index b7bfa66b41cb..07c9b346be04 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,12 +13,12 @@ url='https://www.qt.io'
license=(GPL3 LGPL3 FDL custom)
pkgdesc='Helps you create viable mapping solutions using the data available from some of the popular location services (android)'
depends=('android-aarch64-qt6-declarative' 'android-aarch64-qt6-positioning')
-makedepends=('android-cmake'' 'android-aarch64-qt6-shadertools' 'qt6-shadertools' 'ninja' 'java-environment-openjdk>=11')
+makedepends=('android-cmake' 'android-aarch64-qt6-shadertools' 'android-aarch64-qt6-declarative' 'qt6-shadertools' 'qt6-declarative' 'ninja' 'java-environment-openjdk>=11')
options=('!strip' '!buildflags' 'staticlibs' '!emptydirs')
groups=(android-${_android_arch}-qt6)
_pkgfqn="qtlocation-everywhere-src-${_qtver}"
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('qtlocation-sha256.txt missing')
+sha256sums=('891d7d64c26617bf1993a6d8b3d206ec9ce5b0a5396146f691b11d895fd86dfb')
build() {
source android-env ${_android_arch}
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
index 95e36acfdaed..001fd9ebe03b 100644
--- a/PKGBUILD.sh.ep
+++ b/PKGBUILD.sh.ep
@@ -8,11 +8,11 @@ url='https://www.qt.io'
license=(GPL3 LGPL3 FDL custom)
pkgdesc='Helps you create viable mapping solutions using the data available from some of the popular location services (android)'
depends=(<%== qt6deps qw(declarative positioning) %>)
-makedepends=('android-cmake<%== $static_suffix %>'' <%== qt6deps qw(shadertools) %> 'qt6-shadertools' 'ninja' 'java-environment-openjdk>=11')
+makedepends=('android-cmake<%== $static_suffix %>' <%== qt6deps qw(shadertools declarative) %> 'qt6-shadertools' 'qt6-declarative' 'ninja' 'java-environment-openjdk>=11')
% \
% content_for additional_cmake_args => begin
\\
-DFEATURE_geoservices_mapbox=OFF \\
-DFEATURE_geoservices_mapboxgl=OFF \\
-DFEATURE_geoservices_nokia=OFF\
-% end \ No newline at end of file
+% end
diff --git a/qtlocation-sha256.txt b/qtlocation-sha256.txt
new file mode 100644
index 000000000000..7af641d2e4bc
--- /dev/null
+++ b/qtlocation-sha256.txt
@@ -0,0 +1 @@
+891d7d64c26617bf1993a6d8b3d206ec9ce5b0a5396146f691b11d895fd86dfb