summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2021-01-05 01:29:50 +0100
committerMartchus2021-01-05 01:29:50 +0100
commit210af779dda4e91fa3ac5bbd45106c5116fe825a (patch)
tree8e60c9219ec49c2a880944c836770c8add8784e4
downloadaur-210af779dda4e91fa3ac5bbd45106c5116fe825a.tar.gz
Initial import; Qt 6.0.0
-rw-r--r--.SRCINFO29
-rw-r--r--0001-Make-windeployqt-an-optional-feature.patch26
-rw-r--r--PKGBUILD63
-rw-r--r--PKGBUILD.sh.ep11
-rw-r--r--qttools-sha256.txt1
5 files changed, 130 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9752957a6024
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = android-aarch64-qt6-tools
+ pkgdesc = A cross-platform application and UI framework (tools, android)
+ pkgver = 6.0.0
+ pkgrel = 1
+ url = https://www.qt.io
+ arch = any
+ groups = android-aarch64-qt6
+ license = GPL3
+ license = LGPL3
+ license = FDL
+ license = custom
+ makedepends = android-cmake
+ makedepends = android-aarch64-qt6-declarative
+ makedepends = qt6-declarative
+ makedepends = qt6-tools
+ makedepends = ninja
+ makedepends = java-environment-openjdk=8
+ depends = android-aarch64-qt6-base
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ options = !emptydirs
+ source = https://download.qt.io/official_releases/qt/6.0/6.0.0/submodules/qttools-everywhere-src-6.0.0.tar.xz
+ source = 0001-Make-windeployqt-an-optional-feature.patch
+ sha256sums = b6dc559db447bf394d09dfb238d5c09108f834139a183888179e855c6566bfae
+ sha256sums = f316cdb87dcc84d1fe9ebd262812118e35571aa0fadd3da6ac3b9f42af19b8bb
+
+pkgname = android-aarch64-qt6-tools
+
diff --git a/0001-Make-windeployqt-an-optional-feature.patch b/0001-Make-windeployqt-an-optional-feature.patch
new file mode 100644
index 000000000000..76a8d8dbd889
--- /dev/null
+++ b/0001-Make-windeployqt-an-optional-feature.patch
@@ -0,0 +1,26 @@
+From 007674dc717498f33a8e30a558e8d6560369a0fd Mon Sep 17 00:00:00 2001
+From: Martchus <martchus@gmx.net>
+Date: Thu, 26 Nov 2020 01:53:27 +0100
+Subject: [PATCH] Make windeployqt an optional feature
+
+Change-Id: I3c797df913c07ed80929b41d367b1ebb41d8400f
+---
+ src/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 770f1cab..d5d34064 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -51,7 +51,7 @@ endif()
+ if(TARGET Qt::DBus)
+ add_subdirectory(qdbus)
+ endif()
+-if(WIN32)
++if(QT_FEATURE_windeployqt)
+ add_subdirectory(windeployqt)
+ endif()
+ if(QT_FEATURE_commandlineparser AND TARGET Qt::Gui AND NOT ANDROID AND NOT QNX AND NOT UIKIT AND NOT WASM)
+--
+2.29.2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..32a33abcd617
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+# Maintainer: Martchus <martchus@gmx.net>
+
+# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
+# you also find the URL of a binary repository.
+
+_android_arch=aarch64
+pkgname=android-$_android_arch-qt6-tools
+_qtver=6.0.0
+pkgver=${_qtver/-/}
+pkgrel=1
+arch=(any)
+url='https://www.qt.io'
+license=(GPL3 LGPL3 FDL custom)
+pkgdesc='A cross-platform application and UI framework (tools, android)'
+depends=('android-aarch64-qt6-base')
+makedepends=('android-cmake' 'android-aarch64-qt6-declarative' 'qt6-declarative' 'qt6-tools' 'ninja' 'java-environment-openjdk=8')
+options=('!strip' '!buildflags' 'staticlibs' '!emptydirs')
+groups=(android-${_android_arch}-qt6)
+_pkgfqn="qttools-everywhere-src-${_qtver}"
+source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz"
+ '0001-Make-windeployqt-an-optional-feature.patch')
+sha256sums=('b6dc559db447bf394d09dfb238d5c09108f834139a183888179e855c6566bfae'
+ 'f316cdb87dcc84d1fe9ebd262812118e35571aa0fadd3da6ac3b9f42af19b8bb')
+
+prepare () {
+ cd $_pkgfqn
+
+ # apply patches; further descriptions can be found in patch files itself
+ for patch in "$srcdir/"*.patch; do
+ msg2 "Applying patch $patch"
+ patch -p1 -i "$patch"
+ done
+}
+
+build() {
+ source android-env ${_android_arch}
+ android-${_android_arch}-cmake -G Ninja -B build-$_android_arch -S $_pkgfqn \
+ -DCMAKE_FIND_ROOT_PATH="${ANDROID_PREFIX}" \
+ -DQT_BINARY_DIR=${ANDROID_PREFIX_BIN} \
+ -DQT_INCLUDE_DIRS_NO_SYSTEM=ON \
+ -DQT_HOST_PATH=/usr \
+ -DANDROID_SDK_ROOT=${ANDROID_HOME} \
+ -DANDROID_NDK_ROOT=${ANDROID_NDK_HOME} \
+ -DANDROID_STL="c++_shared" \
+ -DFEATURE_pkg_config=ON
+ cmake --build build-$_android_arch
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build-$_android_arch
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "$pkgdir/${ANDROID_PREFIX}" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+
+ find ${pkgdir}/${ANDROID_PREFIX} -type f -name 'lib*.so' -exec ${ANDROID_STRIP} -g --strip-unneeded {} \;
+ find ${pkgdir}/${ANDROID_PREFIX} -type f -name 'lib*.a' -exec ${ANDROID_STRIP} -g {} \;
+ [[ -d "${pkgdir}/${ANDROID_PREFIX}/share/doc" ]] && rm -r "${pkgdir}/${ANDROID_PREFIX}/share/doc" || true
+
+ install -d "$pkgdir"/usr/share/licenses
+ ln -s /usr/share/licenses/android-$_android_arch-qt6-base "$pkgdir"/usr/share/licenses/$pkgname
+
+}
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
new file mode 100644
index 000000000000..79b584be5079
--- /dev/null
+++ b/PKGBUILD.sh.ep
@@ -0,0 +1,11 @@
+% layout 'android-qt6-module', has_binaries => 1;
+\
+_qtver=6.0.0
+pkgver=${_qtver/-/}
+pkgrel=1
+arch=(any)
+url='https://www.qt.io'
+license=(GPL3 LGPL3 FDL custom)
+pkgdesc='A cross-platform application and UI framework (tools, android)'
+depends=(<%== qt6deps qw(base) %>)
+makedepends=('android-cmake<%== $static_suffix %>' <%== qt6deps qw(declarative) %> 'qt6-declarative' 'qt6-tools' 'ninja' 'java-environment-openjdk=8')
diff --git a/qttools-sha256.txt b/qttools-sha256.txt
new file mode 100644
index 000000000000..253cf3ba23b1
--- /dev/null
+++ b/qttools-sha256.txt
@@ -0,0 +1 @@
+b6dc559db447bf394d09dfb238d5c09108f834139a183888179e855c6566bfae