summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2024-02-25 18:20:24 +0100
committerMartchus2024-02-25 18:20:24 +0100
commit61609b894f734b0404a83cfe304cf989c8eca226 (patch)
tree27354ab29470829183d399db9cc9354989aec142
parent721bd9987bee0a500a1a065f55445e13b87793ca (diff)
downloadaur-61609b894f734b0404a83cfe304cf989c8eca226.tar.gz
Force Android Qt 6 packages to use Java 17
This may help to prevent https://bugreports.qt.io/browse/QTBUG-119223.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD3
-rw-r--r--PKGBUILD.sh.ep2
3 files changed, 4 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 976eb0774490..17f344027d73 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -13,7 +13,7 @@ pkgbase = android-aarch64-qt6-virtualkeyboard
makedepends = qt6-declarative
makedepends = qt6-shadertools
makedepends = ninja
- makedepends = java-environment-openjdk>=11
+ makedepends = java-environment-openjdk=17
depends = android-aarch64-qt6-declarative
depends = android-aarch64-qt6-svg
options = !strip
diff --git a/PKGBUILD b/PKGBUILD
index e5bd52a11ef1..e9d4a5877edc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@ url='https://www.qt.io'
license=(GPL3 LGPL3 FDL custom)
pkgdesc='Virtual keyboard framework (android)'
depends=('android-aarch64-qt6-declarative' 'android-aarch64-qt6-svg')
-makedepends=('android-cmake' 'qt6-declarative' 'qt6-shadertools' 'ninja' 'java-environment-openjdk>=11')
+makedepends=('android-cmake' 'qt6-declarative' 'qt6-shadertools' 'ninja' 'java-environment-openjdk=17')
options=('!strip' '!buildflags' 'staticlibs' '!emptydirs')
groups=(android-${_android_arch}-qt6)
_pkgfqn="qtvirtualkeyboard-everywhere-src-${_qtver}"
@@ -21,6 +21,7 @@ source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/subm
sha256sums=('6142fddb88eb3ed03a97e0d86f7b3121207845b3ec84a92522a78b97886ed81e')
build() {
+ export PATH=/usr/lib/jvm/java-17-openjdk/bin:$PATH
source android-env ${_android_arch}
android-${_android_arch}-cmake -G Ninja -B build-$_android_arch -S $_pkgfqn \
-DCMAKE_FIND_ROOT_PATH="${ANDROID_PREFIX}" \
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
index 1d420ba72134..fdad41d80fad 100644
--- a/PKGBUILD.sh.ep
+++ b/PKGBUILD.sh.ep
@@ -8,4 +8,4 @@ url='https://www.qt.io'
license=(GPL3 LGPL3 FDL custom)
pkgdesc='Virtual keyboard framework (android)'
depends=(<%== qt6deps qw(declarative svg) %>)
-makedepends=('android-cmake<%== $static_suffix %>' 'qt6-declarative' 'qt6-shadertools' 'ninja' 'java-environment-openjdk>=11')
+makedepends=('android-cmake<%== $static_suffix %>' 'qt6-declarative' 'qt6-shadertools' 'ninja' 'java-environment-openjdk=17')