summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2021-10-02 12:48:14 +0200
committerMartchus2021-10-02 12:48:14 +0200
commit9c0bd81412e954faa2a16ce10ffcd48a7c6da34d (patch)
tree7cd684ac923ad4456647a18305eb5b28c105bc7b
downloadaur-9c0bd81412e954faa2a16ce10ffcd48a7c6da34d.tar.gz
Update to 6.2.0
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD51
-rw-r--r--PKGBUILD.sh.ep11
-rw-r--r--qtwebchannel-sha256.txt1
4 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..778c228e7c35
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = android-aarch64-qt6-webchannel
+ pkgdesc = Provides access to QObject or QML objects from HTML clients for seamless integration of Qt applications with HTML/JavaScript clients (android)
+ pkgver = 6.2.0
+ pkgrel = 1
+ url = https://www.qt.io
+ arch = any
+ groups = android-aarch64-qt6
+ license = GPL3
+ license = LGPL3
+ license = FDL
+ license = custom
+ makedepends = android-cmake
+ makedepends = qt6-declarative
+ makedepends = ninja
+ makedepends = java-environment-openjdk=8
+ depends = android-aarch64-qt6-declarative
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ options = !emptydirs
+ source = https://download.qt.io/official_releases/qt/6.2/6.2.0/submodules/qtwebchannel-everywhere-src-6.2.0.tar.xz
+ sha256sums = 518391ed74b087da3c15058c9c17760204425599ef3ffe61b1b73edc2028c171
+
+pkgname = android-aarch64-qt6-webchannel
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0bc1f93e0fc9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Martchus <martchus@gmx.net>
+
+# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
+# you also find the URL of a binary repository.
+
+_android_arch=aarch64
+pkgname=android-$_android_arch-qt6-webchannel
+_qtver=6.2.0
+pkgver=${_qtver/-/}
+pkgrel=1
+arch=(any)
+url='https://www.qt.io'
+license=(GPL3 LGPL3 FDL custom)
+pkgdesc='Provides access to QObject or QML objects from HTML clients for seamless integration of Qt applications with HTML/JavaScript clients (android)'
+depends=('android-aarch64-qt6-declarative')
+makedepends=('android-cmake' 'qt6-declarative' 'ninja' 'java-environment-openjdk=8')
+options=('!strip' '!buildflags' 'staticlibs' '!emptydirs')
+groups=(android-${_android_arch}-qt6)
+_pkgfqn="qtwebchannel-everywhere-src-${_qtver}"
+source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz")
+sha256sums=('518391ed74b087da3c15058c9c17760204425599ef3ffe61b1b73edc2028c171')
+
+build() {
+ source android-env ${_android_arch}
+ android-${_android_arch}-cmake -G Ninja -B build-$_android_arch -S $_pkgfqn \
+ -DCMAKE_FIND_ROOT_PATH="${ANDROID_PREFIX}" \
+ -DQT_BINARY_DIR=${ANDROID_PREFIX_BIN} \
+ -DQT_INCLUDE_DIRS_NO_SYSTEM=ON \
+ -DQT_HOST_PATH=/usr \
+ -DANDROID_SDK_ROOT=${ANDROID_HOME} \
+ -DANDROID_NDK_ROOT=${ANDROID_NDK_HOME} \
+ -DANDROID_STL="c++_shared" \
+ -DFEATURE_pkg_config=ON
+ cmake --build build-$_android_arch
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build-$_android_arch
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "$pkgdir/${ANDROID_PREFIX}" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+
+ find ${pkgdir}/${ANDROID_PREFIX} -type f -name 'lib*.so' -exec ${ANDROID_STRIP} -g --strip-unneeded {} \;
+ find ${pkgdir}/${ANDROID_PREFIX} -type f -name 'lib*.a' -exec ${ANDROID_STRIP} -g {} \;
+ [[ -d "${pkgdir}/${ANDROID_PREFIX}/share/doc" ]] && rm -r "${pkgdir}/${ANDROID_PREFIX}/share/doc" || true
+
+ install -d "$pkgdir"/usr/share/licenses
+ ln -s /usr/share/licenses/android-$_android_arch-qt6-base "$pkgdir"/usr/share/licenses/$pkgname
+
+}
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
new file mode 100644
index 000000000000..9b5d8a3e3be1
--- /dev/null
+++ b/PKGBUILD.sh.ep
@@ -0,0 +1,11 @@
+% layout 'android-qt6-module';
+\
+_qtver=6.2.0
+pkgver=${_qtver/-/}
+pkgrel=1
+arch=(any)
+url='https://www.qt.io'
+license=(GPL3 LGPL3 FDL custom)
+pkgdesc='Provides access to QObject or QML objects from HTML clients for seamless integration of Qt applications with HTML/JavaScript clients (android)'
+depends=(<%== qt6deps qw(declarative) %>)
+makedepends=('android-cmake<%== $static_suffix %>' 'qt6-declarative' 'ninja' 'java-environment-openjdk=8')
diff --git a/qtwebchannel-sha256.txt b/qtwebchannel-sha256.txt
new file mode 100644
index 000000000000..8439142d860b
--- /dev/null
+++ b/qtwebchannel-sha256.txt
@@ -0,0 +1 @@
+518391ed74b087da3c15058c9c17760204425599ef3ffe61b1b73edc2028c171