summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2024-02-25 18:20:41 +0100
committerMartchus2024-02-25 18:20:41 +0100
commitac556b80ca42bc21f5c6c320734307fc4ce77f87 (patch)
treef33000e04b96621af714dabd2753e14b31019054
parentebcb9dc5b5885e9d650bf163f08c2291f5d9cc19 (diff)
downloadaur-ac556b80ca42bc21f5c6c320734307fc4ce77f87.tar.gz
Force Android Qt 6 packages to use Java 17
This may help to prevent https://bugreports.qt.io/browse/QTBUG-119223.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD3
-rw-r--r--PKGBUILD.sh.ep2
3 files changed, 4 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7550cf5ce1ec..489f91cc3def 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -12,7 +12,7 @@ pkgbase = android-aarch64-qt6-webchannel
makedepends = android-cmake
makedepends = qt6-declarative
makedepends = ninja
- makedepends = java-environment-openjdk>=11
+ makedepends = java-environment-openjdk=17
depends = android-aarch64-qt6-declarative
options = !strip
options = !buildflags
diff --git a/PKGBUILD b/PKGBUILD
index 2f527a90aa4c..d984c2c60e7f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@ url='https://www.qt.io'
license=(GPL3 LGPL3 FDL custom)
pkgdesc='Provides access to QObject or QML objects from HTML clients for seamless integration of Qt applications with HTML/JavaScript clients (android)'
depends=('android-aarch64-qt6-declarative')
-makedepends=('android-cmake' 'qt6-declarative' 'ninja' 'java-environment-openjdk>=11')
+makedepends=('android-cmake' 'qt6-declarative' 'ninja' 'java-environment-openjdk=17')
options=('!strip' '!buildflags' 'staticlibs' '!emptydirs')
groups=(android-${_android_arch}-qt6)
_pkgfqn="qtwebchannel-everywhere-src-${_qtver}"
@@ -21,6 +21,7 @@ source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/subm
sha256sums=('3d7c7d3999a394aa337bf575e33e526b058922e3760b34c942e5c8c174dcccc6')
build() {
+ export PATH=/usr/lib/jvm/java-17-openjdk/bin:$PATH
source android-env ${_android_arch}
android-${_android_arch}-cmake -G Ninja -B build-$_android_arch -S $_pkgfqn \
-DCMAKE_FIND_ROOT_PATH="${ANDROID_PREFIX}" \
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
index a32007af7fdd..4989096464f9 100644
--- a/PKGBUILD.sh.ep
+++ b/PKGBUILD.sh.ep
@@ -8,4 +8,4 @@ url='https://www.qt.io'
license=(GPL3 LGPL3 FDL custom)
pkgdesc='Provides access to QObject or QML objects from HTML clients for seamless integration of Qt applications with HTML/JavaScript clients (android)'
depends=(<%== qt6deps qw(declarative) %>)
-makedepends=('android-cmake<%== $static_suffix %>' 'qt6-declarative' 'ninja' 'java-environment-openjdk>=11')
+makedepends=('android-cmake<%== $static_suffix %>' 'qt6-declarative' 'ninja' 'java-environment-openjdk=17')