summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2021-07-22 22:44:56 +0800
committerlilac2021-07-22 22:44:56 +0800
commitbd18c2552756d525ad6b4acb52a740cfc7132b10 (patch)
tree5520dc2a625bfcd94f7493f71c6a39747fd29b31
parent003dc72b4aaa2e36ccdf41161e36dd93ef5117a8 (diff)
downloadaur-bd18c2552756d525ad6b4acb52a740cfc7132b10.tar.gz
[lilac] updated to 5.13-2
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD15
-rw-r--r--issue189.patch31
3 files changed, 48 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 50b7049134f5..f96df61ffdf6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = android-aarch64-strace
pkgdesc = A diagnostic, debugging and instructional userspace tracer (Android, aarch64)
- pkgver = 5.12
+ pkgver = 5.13
pkgrel = 2
url = https://strace.io/
arch = any
@@ -8,11 +8,12 @@ pkgbase = android-aarch64-strace
makedepends = android-ndk
options = !buildflags
options = !strip
- source = https://github.com/strace/strace/releases/download/v5.12/strace-5.12.tar.xz
- source = https://github.com/strace/strace/releases/download/v5.12/strace-5.12.tar.xz.asc
+ source = https://github.com/strace/strace/releases/download/v5.13/strace-5.13.tar.xz
+ source = https://github.com/strace/strace/releases/download/v5.13/strace-5.13.tar.xz.asc
+ source = issue189.patch
validpgpkeys = 296D6F29A020808E8717A8842DB5BD89A340AEB7
- sha256sums = 29171edf9d252f89c988a4c340dfdec662f458cb8c63d85431d64bab5911e7c4
+ sha256sums = 5acc34888b9d510ad6ac915d4a8df08f51cf1ae920ea24649f6a4bb984d0b656
sha256sums = SKIP
+ sha256sums = 2faa94e2c4205b698740868d0de39a060f2e8389e37732a5731cd008edb08dd0
pkgname = android-aarch64-strace
-
diff --git a/PKGBUILD b/PKGBUILD
index 1815acf04c76..f8fed4eaae78 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
_pkgname=strace
_pkg_arch=aarch64
pkgname=android-${_pkg_arch/_/-}-$_pkgname
-pkgver=5.12
+pkgver=5.13
pkgrel=2
pkgdesc="A diagnostic, debugging and instructional userspace tracer (Android, $_pkg_arch)"
arch=(any)
@@ -14,11 +14,18 @@ url='https://strace.io/'
license=(BSD)
makedepends=(android-ndk)
options=(!buildflags !strip)
-source=(https://github.com/strace/strace/releases/download/v$pkgver/strace-$pkgver.tar.xz{,.asc})
-sha256sums=('29171edf9d252f89c988a4c340dfdec662f458cb8c63d85431d64bab5911e7c4'
- 'SKIP')
+source=(https://github.com/strace/strace/releases/download/v$pkgver/strace-$pkgver.tar.xz{,.asc}
+ issue189.patch)
+sha256sums=('5acc34888b9d510ad6ac915d4a8df08f51cf1ae920ea24649f6a4bb984d0b656'
+ 'SKIP'
+ '2faa94e2c4205b698740868d0de39a060f2e8389e37732a5731cd008edb08dd0')
validpgpkeys=('296D6F29A020808E8717A8842DB5BD89A340AEB7') # Dmitry V. Levin <ldv@altlinux.org>
+prepare() {
+ cd $_pkgname-$pkgver
+ patch -Np1 -i ../issue189.patch
+}
+
build() {
cd $_pkgname-$pkgver
export PATH="/opt/android-ndk/toolchains/llvm/prebuilt/linux-x86_64/bin:$PATH"
diff --git a/issue189.patch b/issue189.patch
new file mode 100644
index 000000000000..6802909b6052
--- /dev/null
+++ b/issue189.patch
@@ -0,0 +1,31 @@
+From d2b1a5d79476f1df2adc1465ac53eefb85a52f50 Mon Sep 17 00:00:00 2001
+From: "Dmitry V. Levin" <ldv@strace.io>
+Date: Wed, 21 Jul 2021 08:00:00 +0000
+Subject: [PATCH] prctl: fix build using bionic libc
+
+* src/prctl.c [__ANDROID__ && !PR_SET_VMA] (PR_SET_VMA): Define.
+* NEWS: Mention this.
+
+Resolves: https://github.com/strace/strace/issues/189
+---
+ NEWS | 1 +
+ src/prctl.c | 6 ++++++
+ 2 files changed, 7 insertions(+)
+
+diff --git a/src/prctl.c b/src/prctl.c
+index 62e79510e..6b645d42b 100644
+--- a/src/prctl.c
++++ b/src/prctl.c
+@@ -13,6 +13,12 @@
+
+ #include <linux/prctl.h>
+
++#ifdef __ANDROID__
++# ifndef PR_SET_VMA
++# define PR_SET_VMA 0x53564d41 /* "SVMA" */
++# endif
++#endif
++
+ #include "xstring.h"
+
+ #include "xlat/prctl_options.h"