summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonzalo Exequiel Pedone2024-02-06 16:40:56 -0300
committerGonzalo Exequiel Pedone2024-02-06 16:40:56 -0300
commit7a229f7f1161eaec3f16ef13fad82b6e13d01590 (patch)
tree74530e531c824f0332d57232b06045d2a5eb9e01
parentd92cb07ab7dbf05cedf7fe84a52546d83b2f19f4 (diff)
downloadaur-7a229f7f1161eaec3f16ef13fad82b6e13d01590.tar.gz
Package updated to 0.22.4.
-rw-r--r--.SRCINFO5
-rw-r--r--0001-Fix-missing-headers.patch11
-rw-r--r--PKGBUILD14
3 files changed, 25 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index abaab337c2b7..3e181b7f902f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = android-aarch64-termcap
pkgdesc = Terminal feature database (android)
pkgver = 1.3.1
- pkgrel = 1
+ pkgrel = 2
url = ftp://ftp.gnu.org/gnu/termcap/
arch = any
license = GPL
@@ -12,7 +12,8 @@ pkgbase = android-aarch64-termcap
options = staticlibs
options = !emptydirs
source = http://ftp.gnu.org/gnu/termcap/termcap-1.3.1.tar.gz
+ source = 0001-Fix-missing-headers.patch
md5sums = ffe6f86e63a3a29fa53ac645faaabdfa
+ md5sums = fca1d4ab693214f13651bc529e6d640c
pkgname = android-aarch64-termcap
-
diff --git a/0001-Fix-missing-headers.patch b/0001-Fix-missing-headers.patch
new file mode 100644
index 000000000000..645e4b79a7da
--- /dev/null
+++ b/0001-Fix-missing-headers.patch
@@ -0,0 +1,11 @@
+--- a/tparam.c 2002-02-25 14:37:24.000000000 -0300
++++ b/tparam.c 2024-02-06 16:26:17.200098056 -0300
+@@ -33,6 +33,8 @@
+ char *realloc ();
+ #endif
+
++#include <unistd.h>
++
+ /* Do this after the include, in case string.h prototypes bcopy. */
+ #if (defined(HAVE_STRING_H) || defined(STDC_HEADERS)) && !defined(bcopy)
+ #define bcopy(s, d, n) memcpy ((d), (s), (n))
diff --git a/PKGBUILD b/PKGBUILD
index 7dfd405d691d..9a2d67ab0e87 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,15 +6,23 @@ _android_arch=aarch64
pkgname=android-${_android_arch}-termcap
pkgver=1.3.1
-pkgrel=1
+pkgrel=2
pkgdesc="Terminal feature database (android)"
arch=('any')
url="ftp://ftp.gnu.org/gnu/termcap/"
license=('GPL' 'LGPL')
depends=('android-ndk')
options=(!strip !buildflags staticlibs !emptydirs)
-source=("http://ftp.gnu.org/gnu/termcap/termcap-${pkgver}.tar.gz")
-md5sums=('ffe6f86e63a3a29fa53ac645faaabdfa')
+source=("http://ftp.gnu.org/gnu/termcap/termcap-${pkgver}.tar.gz"
+ "0001-Fix-missing-headers.patch")
+md5sums=('ffe6f86e63a3a29fa53ac645faaabdfa'
+ 'fca1d4ab693214f13651bc529e6d640c')
+
+prepare() {
+ cd "${srcdir}"/termcap-${pkgver}
+
+ patch -Np1 -i ../0001-Fix-missing-headers.patch
+}
build() {
cd "${srcdir}"/termcap-${pkgver}