summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonzalo Exequiel Pedone2021-07-06 19:45:53 -0300
committerGonzalo Exequiel Pedone2021-07-06 19:45:53 -0300
commit9b4b612945bf1eb8dfe14569c52a418b67ca080b (patch)
tree816b4e9f2462f7aa29723f6cc49090a83af2e106
parentfb6f20f283801be3337dc8b5c09bcf7afffa0562 (diff)
downloadaur-android-aarch64-x265.tar.gz
Updated to 3.5.
-rw-r--r--.SRCINFO13
-rw-r--r--0001-Disable-neon.patch19
-rw-r--r--PKGBUILD28
3 files changed, 47 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 52cad97b6a39..cc3a0f7559dc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = android-aarch64-x265
pkgdesc = Open Source H265/HEVC video encoder (android)
- pkgver = 3.3
- pkgrel = 2
- url = https://github.com/videolan/x265
+ pkgver = 3.5
+ pkgrel = 1
+ url = https://bitbucket.org/multicoreware/x265_git
arch = any
license = GPL
makedepends = android-cmake
@@ -12,8 +12,9 @@ pkgbase = android-aarch64-x265
options = !buildflags
options = staticlibs
options = !emptydirs
- source = https://github.com/videolan/x265/archive/3.3.tar.gz
- sha256sums = ca25a38772fc6b49e5f1aa88733bc1dc92da7dc18f02a85cc3e99d76ba85b0a9
+ source = https://bitbucket.org/multicoreware/x265_git/downloads/x265_3.5.tar.gz
+ source = 0001-Disable-neon.patch
+ md5sums = deb5df5cb2ec17bdbae6ac6bbc3b1eef
+ md5sums = fffb730725e5848d6f1fd87e50530452
pkgname = android-aarch64-x265
-
diff --git a/0001-Disable-neon.patch b/0001-Disable-neon.patch
new file mode 100644
index 000000000000..aaab6cab8215
--- /dev/null
+++ b/0001-Disable-neon.patch
@@ -0,0 +1,19 @@
+--- a/source/CMakeLists.txt 2021-03-16 09:53:00.000000000 -0300
++++ b/source/CMakeLists.txt 2021-07-06 19:13:30.236573538 -0300
+@@ -248,7 +248,6 @@
+ elseif(ARM)
+ if(ARM64)
+ set(ARM_ARGS -fPIC)
+- add_definitions(-DHAVE_NEON)
+ else()
+ find_package(Neon)
+ if(CPU_HAS_NEON)
+@@ -351,7 +350,7 @@
+
+ find_package(Nasm)
+ if(ARM OR CROSS_COMPILE_ARM)
+- option(ENABLE_ASSEMBLY "Enable use of assembly coded primitives" ON)
++ option(ENABLE_ASSEMBLY "Enable use of assembly coded primitives" OFF)
+ elseif(NASM_FOUND AND X86)
+ if (NASM_VERSION_STRING VERSION_LESS "2.13.0")
+ message(STATUS "Nasm version ${NASM_VERSION_STRING} is too old. 2.13.0 or later required")
diff --git a/PKGBUILD b/PKGBUILD
index d5c6adc12d1f..97fe689feb6a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,20 +3,34 @@
_android_arch=aarch64
pkgname=android-${_android_arch}-x265
-pkgver=3.3
-pkgrel=2
+pkgver=3.5
+pkgrel=1
arch=('any')
pkgdesc='Open Source H265/HEVC video encoder (android)'
license=('GPL')
-url='https://github.com/videolan/x265'
+url='https://bitbucket.org/multicoreware/x265_git'
depends=('android-ndk')
options=(!strip !buildflags staticlibs !emptydirs)
makedepends=('android-cmake' 'nasm')
-source=("https://github.com/videolan/x265/archive/${pkgver}.tar.gz")
-sha256sums=('ca25a38772fc6b49e5f1aa88733bc1dc92da7dc18f02a85cc3e99d76ba85b0a9')
+source=("https://bitbucket.org/multicoreware/x265_git/downloads/x265_${pkgver}.tar.gz"
+ "0001-Disable-neon.patch")
+md5sums=('deb5df5cb2ec17bdbae6ac6bbc3b1eef'
+ 'fffb730725e5848d6f1fd87e50530452')
+
+prepare() {
+ cd "${srcdir}"/x265_${pkgver}
+
+ case "$_android_arch" in
+ aarch64)
+ patch -Np1 -i "../0001-Disable-neon.patch"
+ ;;
+ *)
+ ;;
+ esac
+}
build() {
- cd "${srcdir}"/x265-${pkgver}
+ cd "${srcdir}"/x265_${pkgver}
source android-env ${_android_arch}
unset LDFLAGS CPPFLAGS
@@ -75,7 +89,7 @@ build() {
}
package() {
- cd "${srcdir}"/x265-${pkgver}/build-8
+ cd "${srcdir}"/x265_${pkgver}/build-8
source android-env ${_android_arch}
make DESTDIR="$pkgdir" install