summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoseph Brains2023-08-04 13:15:05 +0300
committerJoseph Brains2023-08-04 13:15:05 +0300
commitf3be03d5eda565eb8f714cdd8aa3ba3fdd358d4b (patch)
tree6554f66eb9f8e5e236b71629622a8530a851d4e9
downloadaur-f3be03d5eda565eb8f714cdd8aa3ba3fdd358d4b.tar.gz
updated to v2.8.1
-rw-r--r--.SRCINFO19
-rw-r--r--Changelog14
-rw-r--r--PKGBUILD24
-rwxr-xr-xapktool77
4 files changed, 134 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b6bd222a5d16
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = android-apktool-bin
+ pkgdesc = A tool for reverse engineering Android apk files
+ pkgver = 2.8.1
+ pkgrel = 1
+ url = https://github.com/iBotPeaches/Apktool
+ changelog = Changelog
+ arch = any
+ license = Apache
+ depends = java-runtime>=8
+ provides = android-apktool
+ conflicts = android-apktool
+ conflicts = android-apktool-git
+ noextract = apktool_2.8.1.jar
+ source = https://github.com/iBotPeaches/Apktool/releases/download/v2.8.1/apktool_2.8.1.jar
+ source = apktool
+ sha256sums = 7b4a8e1703e228d206db29644b71141687d8a111b55b039b08b02dfa443ab0f9
+ sha256sums = f1d4cf2eb2d12512dbbe583cd7fb35b8b8a44e0e3a1d5e88015ab01d9bc1ce62
+
+pkgname = android-apktool-bin
diff --git a/Changelog b/Changelog
new file mode 100644
index 000000000000..839faf9564be
--- /dev/null
+++ b/Changelog
@@ -0,0 +1,14 @@
+v2.8.1
+
+ - feat: Upgrade gradle to v8.2.1 by @ArjunaKumarMohanta in #3141
+ - build(deps): bump gradle/gradle-build-action from 2.5.1 to 2.6.0 by @dependabot in #3151
+ - fix: skip files if cleaned to empty filename by @iBotPeaches in #3166
+ - fix: opt out of stricter java rules for zip64 and dot entries by @iBotPeaches in #3178
+ - build: test on java20 by @iBotPeaches in #3177
+ - Correct regressions towards apktool.yml generation by @iBotPeaches in #3172
+ - Allows run app from gradle for debugging purposes by @sv99 in #3179
+ - fix: add missing hasResources check by @IgorEisberg in #3182
+ - Prevent loading from resource pool if type is not a resolveable resource by @iBotPeaches in #3187
+ - style: normalize command descs and redundancy by @IgorEisberg in #3188
+ - fix: crash when decompiling framework-res.apk with a tag (regression) by @IgorEisberg in #3193
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d50cb9b56225
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Joseph Brains <jnbrains at gmail dot com>
+
+_pkgname=android-apktool
+pkgname=${_pkgname}-bin
+pkgver=2.8.1
+pkgrel=1
+pkgdesc='A tool for reverse engineering Android apk files'
+arch=('any')
+url='https://github.com/iBotPeaches/Apktool'
+license=('Apache')
+depends=('java-runtime>=8')
+conflicts=('android-apktool' 'android-apktool-git')
+provides=('android-apktool')
+source=("https://github.com/iBotPeaches/Apktool/releases/download/v${pkgver}/apktool_${pkgver}.jar"
+ 'apktool')
+noextract=("apktool_${pkgver}.jar")
+sha256sums=('7b4a8e1703e228d206db29644b71141687d8a111b55b039b08b02dfa443ab0f9'
+ 'f1d4cf2eb2d12512dbbe583cd7fb35b8b8a44e0e3a1d5e88015ab01d9bc1ce62')
+changelog=Changelog
+
+package() {
+ install -Dm 0755 "${srcdir}/apktool" "${pkgdir}/usr/bin/apktool"
+ install -Dm 0644 "${srcdir}/apktool_${pkgver}.jar" "${pkgdir}/usr/share/${_pkgname}/apktool.jar"
+}
diff --git a/apktool b/apktool
new file mode 100755
index 000000000000..676eb5b105ab
--- /dev/null
+++ b/apktool
@@ -0,0 +1,77 @@
+#!/bin/bash
+#
+# Copyright (C) 2007 The Android Open Source Project
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+# This script is a wrapper for smali.jar, so you can simply call "smali",
+# instead of java -jar smali.jar. It is heavily based on the "dx" script
+# from the Android SDK
+
+# Set up prog to be the path of this script, including following symlinks,
+# and set up progdir to be the fully-qualified pathname of its directory.
+prog="$0"
+while [ -h "${prog}" ]; do
+ newProg=`/bin/ls -ld "${prog}"`
+ echo ${newProg}
+
+
+ newProg=`expr "${newProg}" : ".* -> \(.*\)$"`
+ if expr "x${newProg}" : 'x/' >/dev/null; then
+ prog="${newProg}"
+ else
+ progdir=`dirname "${prog}"`
+ prog="${progdir}/${newProg}"
+ fi
+done
+oldwd=`pwd`
+progdir=`dirname "${prog}"`
+cd "${progdir}"
+progdir=`pwd`
+prog="${progdir}"/`basename "${prog}"`
+cd "${oldwd}"
+
+
+jarfile=apktool.jar
+libdir="/usr/share/android-apktool"
+if [ ! -r "$libdir/$jarfile" ]
+then
+ echo `basename "$prog"`": can't find $jarfile"
+ exit 1
+fi
+
+javaOpts=""
+
+# If you want DX to have more memory when executing, uncomment the following
+# line and adjust the value accordingly. Use "java -X" for a list of options
+# you can pass here.
+#
+javaOpts="-Xmx256M"
+
+# Alternatively, this will extract any parameter "-Jxxx" from the command line
+# and pass them to Java (instead of to dx). This makes it possible for you to
+# add a command-line parameter such as "-JXmx256M" in your ant scripts, for
+# example.
+while expr "x$1" : 'x-J' >/dev/null; do
+ opt=`expr "$1" : '-J\(.*\)'`
+ javaOpts="${javaOpts} -${opt}"
+ shift
+done
+
+if [ "$OSTYPE" = "cygwin" ] ; then
+ jarpath=`cygpath -w "$libdir/$jarfile"`
+else
+ jarpath="$libdir/$jarfile"
+fi
+
+exec java $javaOpts -jar "$jarpath" "$@"