summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYen Chi Hsuan2017-10-15 21:24:26 +0800
committerYen Chi Hsuan2017-10-15 21:24:26 +0800
commit73cbdacaf7dcb743b9f7fe07efc9bafb156581e1 (patch)
treefb62801ce07c12472cdcfe0e4574c7a1afb408d9
parent8b8a1859b4166c3423654c165b94879fffccf2c1 (diff)
downloadaur-73cbdacaf7dcb743b9f7fe07efc9bafb156581e1.tar.gz
Fix building
openjdk7 fails with "EC parameters error" during downloading the gradle pluin, which is fixed in openjdk8. Ref: https://github.com/gradle/gradle/issues/2421
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
2 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 715811220cbc..e7dc88020466 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,9 +6,9 @@ pkgbase = android-apktool-git
arch = any
license = Apache
makedepends = git
- makedepends = java-environment
+ makedepends = java-environment>=8
depends = bash
- depends = java-runtime
+ depends = java-runtime>=8
depends = android-sdk-build-tools
conflicts = android-apktool
source = git+https://github.com/iBotPeaches/Apktool.git
diff --git a/PKGBUILD b/PKGBUILD
index a4eb7c17e206..fed978a27f87 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,9 +10,9 @@ pkgdesc="a tool for reengineering Android apk files"
arch=(any)
url="https://ibotpeaches.github.io/Apktool/"
license=(Apache)
-depends=(bash java-runtime android-sdk-build-tools)
+depends=(bash 'java-runtime>=8' android-sdk-build-tools)
conflicts=(android-apktool)
-makedepends=(git java-environment) # openjdk has had issues in the past, be warned!
+makedepends=(git 'java-environment>=8') # openjdk has had issues in the past, be warned!
source=("git+https://github.com/iBotPeaches/$_gitname.git")
sha512sums=('SKIP')