summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Manouchehri2015-12-16 18:57:22 +0000
committerDavid Manouchehri2015-12-16 18:57:22 +0000
commit7a07900e76baf5c69e75f5292d02bf33ad470cd4 (patch)
treef6549fb984a1d28dd0a549bc7a5cde9b812a703e
parent55ede93a632f2f3ffaeebaaf8190eeef323a2f5c (diff)
downloadaur-7a07900e76baf5c69e75f5292d02bf33ad470cd4.tar.gz
Apply smali patches.
Source: https://ibotpeaches.github.io/Apktool/build/
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 70fd5ba35db7..7b5743f6ae4e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -27,11 +27,13 @@ build() {
# aapt cannot be found without this line
PATH="/opt/android-sdk/build-tools/$(ls -1 /opt/android-sdk/build-tools/ | head -1):$PATH"
-
+
cd "$srcdir/$_gitname"
+ ./gradlew applyPatches
+
# Build (OpenJDK sometimes fails to find aapt)
- ./gradlew build fatJar proguard # proguard isn't needed, but makes the binary a little bit smaller
+ ./gradlew build fatJar proguard # proguard isn't needed, but makes the binary a little bit smaller
}
package() {