summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYen Chi Hsuan2017-08-05 23:43:54 +0800
committerYen Chi Hsuan2017-08-05 23:43:54 +0800
commit8b8a1859b4166c3423654c165b94879fffccf2c1 (patch)
treec426009c404fd68fc1f8db55bbeca8735ab2f833
parent9aa7f90ce7499d47d9e0720075e9511ea77aa704 (diff)
downloadaur-8b8a1859b4166c3423654c165b94879fffccf2c1.tar.gz
Bump to 2.2.4.r5.g2f387288
Adopt, fix and cleanup
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
2 files changed, 18 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2ba347582f3a..715811220cbc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,17 @@
-# Generated by makepkg 4.2.1
-# Thu Mar 12 20:44:03 UTC 2015
pkgbase = android-apktool-git
pkgdesc = a tool for reengineering Android apk files
- pkgver = 2.0.0.RC4.r20.gbbc6023
+ pkgver = 2.2.4.r5.g2f387288
pkgrel = 1
- url = https://code.google.com/p/android-apktool/
- arch = i686
- arch = x86_64
- license = Apache 2.0
+ url = https://ibotpeaches.github.io/Apktool/
+ arch = any
+ license = Apache
makedepends = git
makedepends = java-environment
+ depends = bash
depends = java-runtime
depends = android-sdk-build-tools
conflicts = android-apktool
- source = git://github.com/iBotPeaches/Apktool.git#branch=master
+ source = git+https://github.com/iBotPeaches/Apktool.git
sha512sums = SKIP
pkgname = android-apktool-git
diff --git a/PKGBUILD b/PKGBUILD
index 142cdd0dba02..a4eb7c17e206 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,19 @@
-# Maintainer: David Manouchehri <manouchehri@riseup.net>
+# Maintainer: Yen Chi Hsuan <yan12125 at gmail.com>
+# Contributor: David Manouchehri <manouchehri@riseup.net>
# Contributor: Philipp 'TamCore' B. <philipp {at} tamcore {dot} eu>
-pkgname=android-apktool-git
_gitname=Apktool
-_gitbranch=master
-_gitauthor=iBotPeaches
-pkgver=2.0.0.RC4.r20.gbbc6023
+pkgname=android-apktool-git
+pkgver=2.2.4.r5.g2f387288
pkgrel=1
pkgdesc="a tool for reengineering Android apk files"
-arch=('i686' 'x86_64')
-url="https://code.google.com/p/android-apktool/"
-license=('Apache 2.0')
-depends=('java-runtime' 'android-sdk-build-tools')
-conflicts=('android-apktool')
-makedepends=('git' 'java-environment') # openjdk has had issues in the past, be warned!
-source=("git://github.com/$_gitauthor/$_gitname.git#branch=$_gitbranch")
+arch=(any)
+url="https://ibotpeaches.github.io/Apktool/"
+license=(Apache)
+depends=(bash java-runtime android-sdk-build-tools)
+conflicts=(android-apktool)
+makedepends=(git java-environment) # openjdk has had issues in the past, be warned!
+source=("git+https://github.com/iBotPeaches/$_gitname.git")
sha512sums=('SKIP')
pkgver() {
@@ -30,10 +29,8 @@ build() {
cd "$srcdir/$_gitname"
- ./gradlew applyPatches
-
# Build (OpenJDK sometimes fails to find aapt)
- ./gradlew build fatJar proguard # proguard isn't needed, but makes the binary a little bit smaller
+ ./gradlew build proguard # proguard isn't needed, but makes the binary a little bit smaller
}
package() {