summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Keen2014-11-27 00:00:43 +0000
committerKyle Keen2014-11-27 00:00:43 +0000
commitc5dbb5490c79c151cd160ae19308a923afc225ac (patch)
tree8c86df6269e79aec13fb6e14e3d00cad136101a1
parent793bfb8156ddec2e0baeb19d043fdf2fec8683c2 (diff)
downloadaur-c5dbb5490c79c151cd160ae19308a923afc225ac.tar.gz
updated on Thu Nov 27 00:00:42 UTC 2014
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 12 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index df8b0b1ed445..b4f9f8fdd7d8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = android-apktool-git
pkgdesc = a tool for reengineering Android apk files
- pkgver = 2.0.0.Beta9.g251a6bb
+ pkgver = 2.0.0.RC2.g02b5c7c
pkgrel = 1
url = https://code.google.com/p/android-apktool/
arch = i686
arch = x86_64
license = Apache 2.0
makedepends = git
- makedepends = jdk7
+ makedepends = java-environment
depends = java-runtime
depends = android-sdk-build-tools
conflicts = android-apktool
- source = git://github.com/iBotPeaches/Apktool.git#branch=wip-2.0
+ source = git://github.com/iBotPeaches/Apktool.git#branch=master
sha512sums = SKIP
pkgname = android-apktool-git
diff --git a/PKGBUILD b/PKGBUILD
index d91a9167fba5..a1f152d0dab1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,9 +3,9 @@
pkgname=android-apktool-git
_gitname=Apktool
-_gitbranch=wip-2.0
+_gitbranch=master
_gitauthor=iBotPeaches
-pkgver=2.0.0.Beta9.g251a6bb
+pkgver=2.0.0.RC2.g02b5c7c
pkgrel=1
pkgdesc="a tool for reengineering Android apk files"
arch=('i686' 'x86_64')
@@ -13,7 +13,7 @@ url="https://code.google.com/p/android-apktool/"
license=('Apache 2.0')
depends=('java-runtime' 'android-sdk-build-tools')
conflicts=('android-apktool')
-makedepends=('git' 'jdk7') # openjdk does not work for some unknown reason
+makedepends=('git' 'java-environment') # openjdk has had issues in the past, be warned!
source=("git://github.com/$_gitauthor/$_gitname.git#branch=$_gitbranch")
sha512sums=('SKIP')
@@ -24,9 +24,14 @@ pkgver() {
}
build() {
+ pacman -Qs openjdk &> /dev/null && printf "\033[31;1mWarning, there has been issues in the past with OpenJDK and apktool. Please install Oracle's JDK before marking the package as broken.\n\033[0m\n"
+
+ # Ideally this should be fixed in the build script of apktool and not here; without it, aapt cannot be found
+ PATH="/opt/android-sdk/build-tools/$(ls -1 /opt/android-sdk/build-tools/ | head -1):$PATH"
+
cd "$srcdir/$_gitname"
- # Build (this is the part where openjdk fails)
+ # Build (OpenJDK sometimes fails to find aapt)
./gradlew build fatJar proguard # proguard isn't needed, but makes the binary a little bit smaller
}