summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2019-09-18 18:03:08 +0200
committerMartchus2019-09-18 18:03:08 +0200
commitcd002f9439786876e6660dc379694c4999c56d2a (patch)
treece79dd7781a8c93743c57accd75fafb5998ec960
parent1440e365231eabc9eaf0aff68286ab2db2fccb69 (diff)
downloadaur-cd002f9439786876e6660dc379694c4999c56d2a.tar.gz
Update to 1.71.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD22
-rw-r--r--disable-version-check.patch27
3 files changed, 44 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d6c8eb2b400d..6f7f6413b3b0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = android-armv7a-eabi-boost
pkgdesc = Free peer-reviewed portable C++ source libraries (Android, armv7a-eabi)
- pkgver = 1.69.0
+ pkgver = 1.71.0
pkgrel = 1
- url = http://www.boost.org/
+ url = https://www.boost.org/
arch = any
license = custom
makedepends = bzip2
@@ -16,10 +16,12 @@ pkgbase = android-armv7a-eabi-boost
options = staticlibs
options = !strip
options = !emptydirs
- source = https://downloads.sourceforge.net/project/boost/boost/1.69.0/boost_1_69_0.tar.bz2
+ source = https://dl.bintray.com/boostorg/release/1.71.0/source/boost_1_71_0.tar.bz2
source = no-versioned-shlibs.patch
- sha256sums = 8f32d4617390d1c2d16f26a27ab60d97807b35440d45891fa340fc2648b04406
+ source = disable-version-check.patch
+ sha256sums = d73a8da01e8bf8c7eda40b4c84915071a8c8a0df4a6734537ddde4a8580524ee
sha256sums = d82d0f15064812dcabb3456a7bcb1db0e0f6145980e4728e638372e0fd35af23
+ sha256sums = 13d7ed51d05dba2dfe04d9929bf0091505883567178586d0b482b0900a684848
pkgname = android-armv7a-eabi-boost
diff --git a/PKGBUILD b/PKGBUILD
index a4083b2b0cb0..ed3f838c3340 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,10 +16,10 @@ _boost_arch=arm
_boost_address_model=32
pkgname=android-$_pkg_arch-$_pkgname
-pkgver=1.69.0
+pkgver=1.71.0
_boostver=${pkgver//./_}
pkgrel=1
-url='http://www.boost.org/'
+url='https://www.boost.org/'
arch=('any')
license=('custom')
pkgdesc="Free peer-reviewed portable C++ source libraries (Android, $_pkg_arch)"
@@ -28,14 +28,17 @@ options=(!buildflags staticlibs !strip !emptydirs)
makedepends=('bzip2' 'zlib' 'android-ndk' 'android-sdk')
conflicts=("android-$_pkgname-$_android_arch")
replaces=("android-$_pkgname-$_android_arch")
-source=(https://downloads.sourceforge.net/project/${_pkgname}/${_pkgname}/${pkgver}/${_pkgname}_${_boostver}.tar.bz2
- no-versioned-shlibs.patch)
-sha256sums=('8f32d4617390d1c2d16f26a27ab60d97807b35440d45891fa340fc2648b04406'
- 'd82d0f15064812dcabb3456a7bcb1db0e0f6145980e4728e638372e0fd35af23')
+source=(https://dl.bintray.com/boostorg/release/${pkgver}/source/boost_${_boostver}.tar.bz2
+ no-versioned-shlibs.patch
+ disable-version-check.patch)
+sha256sums=('d73a8da01e8bf8c7eda40b4c84915071a8c8a0df4a6734537ddde4a8580524ee'
+ 'd82d0f15064812dcabb3456a7bcb1db0e0f6145980e4728e638372e0fd35af23'
+ '13d7ed51d05dba2dfe04d9929bf0091505883567178586d0b482b0900a684848')
prepare() {
cd ${_pkgname}_${_boostver}
patch -i ../no-versioned-shlibs.patch
+ patch -p1 -i ../disable-version-check.patch
}
build() {
@@ -67,9 +70,7 @@ build() {
./bootstrap.sh --with-toolset=gcc
- _bindir="bin.linuxx86"
- [[ "${CARCH}" = "x86_64" ]] && _bindir="bin.linuxx86_64"
- install -Dm755 tools/build/src/engine/$_bindir/b2 "${_stagedir}"/bin/b2
+ install -Dm755 tools/build/src/engine/b2 "${_stagedir}"/bin/b2
# Support for OpenMPI
echo "using mpi ;" >> project-config.jam
@@ -121,7 +122,7 @@ build() {
toolset=clang-android \
architecture=$_boost_arch \
address-model=$_boost_address_model \
- -sICONV_PATH="/opt/android-libs/$_android_arch" \
+ -sICONV_PATH="/opt/android-libs/$_pkg_arch" \
cflags="$common_flags" \
cxxflags="$common_flags -fexceptions -frtti -std=c++14" \
linkflags="$ld_flags" \
@@ -129,7 +130,6 @@ build() {
${jobs} \
\
--prefix="${_stagedir}" \
- -d+2 \
install
}
diff --git a/disable-version-check.patch b/disable-version-check.patch
new file mode 100644
index 000000000000..3469b005b9d2
--- /dev/null
+++ b/disable-version-check.patch
@@ -0,0 +1,27 @@
+--- a/tools/build/src/tools/common.jam 2019-09-18 16:03:02.035995695 +0200
++++ b/tools/build/src/tools/common.jam 2019-09-18 16:03:36.386156355 +0200
+@@ -974,16 +974,16 @@
+ }
+
+ # From GCC 5, versioning changes and minor becomes patch
+- if $(tag) = gcc && [ numbers.less 4 $(version[1]) ]
+- {
+- version = $(version[1]) ;
+- }
++ #if $(tag) = gcc && [ numbers.less 4 $(version[1]) ]
++ #{
++ # version = $(version[1]) ;
++ #}
+
+ # Ditto, from Clang 4
+- if ( $(tag) = clang || $(tag) = clangw ) && [ numbers.less 3 $(version[1]) ]
+- {
+- version = $(version[1]) ;
+- }
++ #if ( $(tag) = clang || $(tag) = clangw ) && [ numbers.less 3 $(version[1]) ]
++ #{
++ # version = $(version[1]) ;
++ #}
+
+ # On intel, version is not added, because it does not matter and it is the
+ # version of vc used as backend that matters. Ideally, we should encode the