summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonzalo Exequiel Pedone2020-01-18 18:10:39 -0300
committerGonzalo Exequiel Pedone2020-01-18 18:10:39 -0300
commit988875cd5d66c47cdb04ab1231f5486d91067ad4 (patch)
treef7976647f0f1653e147e89f461129efa4ecc6d28
parenteb990b4e3f9456f25c4196c5ec2c1ebfe2d0820e (diff)
downloadaur-988875cd5d66c47cdb04ab1231f5486d91067ad4.tar.gz
Added libssh support.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9c5a11716689..a1e697bfe627 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = android-armv7a-eabi-ffmpeg
pkgdesc = Complete solution to record, convert and stream audio and video (android)
pkgver = 4.2.2
- pkgrel = 1
+ pkgrel = 2
url = http://ffmpeg.org/
arch = any
license = GPL3
@@ -10,6 +10,7 @@ pkgbase = android-armv7a-eabi-ffmpeg
makedepends = yasm
depends = android-armv7a-eabi-bzip2
depends = android-armv7a-eabi-lame
+ depends = android-armv7a-eabi-libssh
depends = android-armv7a-eabi-libtheora
depends = android-armv7a-eabi-libvorbis
depends = android-armv7a-eabi-libvpx
diff --git a/PKGBUILD b/PKGBUILD
index 58114e5bb619..45fc4c6c6fb1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,14 @@ _android_arch=armv7a-eabi
pkgname=android-${_android_arch}-ffmpeg
pkgver=4.2.2
-pkgrel=1
+pkgrel=2
pkgdesc="Complete solution to record, convert and stream audio and video (android)"
arch=('any')
url="http://ffmpeg.org/"
license=('GPL3')
depends=("android-${_android_arch}-bzip2"
"android-${_android_arch}-lame"
+ "android-${_android_arch}-libssh"
"android-${_android_arch}-libtheora"
"android-${_android_arch}-libvorbis"
"android-${_android_arch}-libvpx"
@@ -48,7 +49,7 @@ build() {
case "$_android_arch" in
aarch64)
target_arch=aarch64
- export LDFLAGS="-L${ANDROID_PREFIX_LIB} -lm -logg -lvorbis"
+ export LDFLAGS="-L${ANDROID_PREFIX_LIB} -lm -logg -lvorbis -lssh -lcrypto_1_1 -lssl_1_1"
;;
armv7a-eabi)
target_arch=arm
@@ -95,6 +96,7 @@ build() {
--enable-libmp3lame
--enable-libopus
--enable-libspeex
+ --enable-libssh
--enable-libtheora
--enable-libvorbis
--enable-libvpx