summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonzalo Exequiel Pedone2020-03-03 12:16:37 -0300
committerGonzalo Exequiel Pedone2020-03-03 12:16:37 -0300
commit2fad581168fd38a8f140393f638c156232ef0dbe (patch)
treece9d0247567b97238c219db39c89f516357708d4
downloadaur-2fad581168fd38a8f140393f638c156232ef0dbe.tar.gz
First commit.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD35
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..20f617ef286e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = android-armv7a-eabi-fribidi
+ pkgdesc = A Free Implementation of the Unicode Bidirectional Algorithm (android)
+ pkgver = 1.0.9
+ pkgrel = 1
+ url = http://fribidi.org
+ arch = any
+ license = LGPL
+ makedepends = android-meson
+ depends = android-ndk
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ options = !emptydirs
+ source = https://github.com/fribidi/fribidi/archive/v1.0.9.tar.gz
+ sha256sums = ef6f940d04213a0fb91a0177b2b57df2031bf3a7e2cd0ee2c6877a160fc206df
+
+pkgname = android-armv7a-eabi-fribidi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e052edb82338
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Gonzalo Exequiel Pedone <hipersayan DOT x AT gmail DOT com>
+# Contributor: Karl-Felix Glatzer <karl[dot]glatzer[at]gmx[dot]de>
+
+_android_arch=armv7a-eabi
+
+pkgname=android-${_android_arch}-fribidi
+pkgver=1.0.9
+pkgrel=1
+pkgdesc="A Free Implementation of the Unicode Bidirectional Algorithm (android)"
+arch=('any')
+url="http://fribidi.org"
+license=('LGPL')
+depends=('android-ndk')
+options=(!strip !buildflags staticlibs !emptydirs)
+makedepends=('android-meson')
+source=("https://github.com/fribidi/fribidi/archive/v${pkgver}.tar.gz")
+sha256sums=('ef6f940d04213a0fb91a0177b2b57df2031bf3a7e2cd0ee2c6877a160fc206df')
+
+build() {
+ cd "${srcdir}"/fribidi-${pkgver}
+ source android-env ${_android_arch}
+
+ android-${_android_arch}-meson build \
+ -D docs=false
+ ninja -C build
+}
+
+package() {
+ cd "${srcdir}"/fribidi-${pkgver}
+ source android-env ${_android_arch}
+
+ DESTDIR="${pkgdir}" meson install -C build
+ rm -r "${pkgdir}"/${ANDROID_PREFIX_BIN}
+ ${ANDROID_STRIP} -g --strip-unneeded "${pkgdir}"/${ANDROID_PREFIX_LIB}/*.so
+}