summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonzalo Exequiel Pedone2024-05-06 14:56:36 -0300
committerGonzalo Exequiel Pedone2024-05-06 14:56:36 -0300
commit8a0d94a3004e0a7fff1b02ff92d38b9a97cc4c90 (patch)
tree00efe9c1974420dee3f768a1ebde4a9449722db5
parent0ce0cef412cf449fc565805d32f8c48e3bef932a (diff)
downloadaur-8a0d94a3004e0a7fff1b02ff92d38b9a97cc4c90.tar.gz
Package updated to 1.0.14.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD18
2 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f8bdccb19633..9d9d0ce098f3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = android-armv7a-eabi-fribidi
- pkgdesc = A Free Implementation of the Unicode Bidirectional Algorithm (android)
- pkgver = 1.0.13
+ pkgdesc = A Free Implementation of the Unicode Bidirectional Algorithm (Android armv7a-eabi)
+ pkgver = 1.0.14
pkgrel = 1
url = http://fribidi.org
arch = any
@@ -11,7 +11,7 @@ pkgbase = android-armv7a-eabi-fribidi
options = !buildflags
options = staticlibs
options = !emptydirs
- source = https://github.com/fribidi/fribidi/archive/v1.0.13.tar.gz
- md5sums = 7aa67eb9a386be40629f35517dd52acf
+ source = https://github.com/fribidi/fribidi/archive/v1.0.14.tar.gz
+ md5sums = 847a2d33a962bbb6c92675b1b6463fdd
pkgname = android-armv7a-eabi-fribidi
diff --git a/PKGBUILD b/PKGBUILD
index 3f18cc64bb7e..6325604a3a92 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,32 +4,32 @@
_android_arch=armv7a-eabi
pkgname=android-${_android_arch}-fribidi
-pkgver=1.0.13
+pkgver=1.0.14
pkgrel=1
-pkgdesc="A Free Implementation of the Unicode Bidirectional Algorithm (android)"
arch=('any')
+pkgdesc="A Free Implementation of the Unicode Bidirectional Algorithm (Android ${_android_arch})"
url="http://fribidi.org"
license=('LGPL')
depends=('android-ndk')
-options=(!strip !buildflags staticlibs !emptydirs)
makedepends=('android-meson')
+options=(!strip !buildflags staticlibs !emptydirs)
source=("https://github.com/fribidi/fribidi/archive/v${pkgver}.tar.gz")
-md5sums=('7aa67eb9a386be40629f35517dd52acf')
+md5sums=('847a2d33a962bbb6c92675b1b6463fdd')
build() {
- cd "${srcdir}"/fribidi-${pkgver}
+ cd "${srcdir}/fribidi-${pkgver}"
source android-env ${_android_arch}
android-${_android_arch}-meson build \
- -D docs=false
+ -Ddocs=false
ninja -C build
}
package() {
- cd "${srcdir}"/fribidi-${pkgver}
+ cd "${srcdir}/fribidi-${pkgver}"
source android-env ${_android_arch}
DESTDIR="${pkgdir}" meson install -C build
- rm -r "${pkgdir}"/${ANDROID_PREFIX_BIN}
- ${ANDROID_STRIP} -g --strip-unneeded "${pkgdir}"/${ANDROID_PREFIX_LIB}/*.so
+ rm -r "${pkgdir}/${ANDROID_PREFIX_BIN}"
+ ${ANDROID_STRIP} -g --strip-unneeded "${pkgdir}/${ANDROID_PREFIX_LIB}"/*.so
}