summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2019-07-15 11:23:06 +0200
committerMartchus2019-07-15 11:23:06 +0200
commit399356a953f4fd678983530446c33c9aa7218995 (patch)
treeb61b6d2c95b1ea4752cb4f3466c696f0c9744f48
downloadaur-399356a953f4fd678983530446c33c9aa7218995.tar.gz
Update to 5.60.0
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD61
2 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ceee4b33fc4b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = android-armv7a-eabi-kirigami2
+ pkgdesc = A QtQuick based components set (Android, armv7a-eabi)
+ pkgver = 5.60.0
+ pkgrel = 1
+ url = https://community.kde.org/Frameworks
+ arch = any
+ license = LGPL
+ makedepends = cmake
+ makedepends = android-ndk
+ makedepends = android-sdk
+ makedepends = extra-cmake-modules
+ depends = android-armv7a-eabi-qt5
+ conflicts = android-kirigami2-armeabi-v7a
+ replaces = android-kirigami2-armeabi-v7a
+ options = !buildflags
+ options = staticlibs
+ options = !strip
+ options = !emptydirs
+ source = https://download.kde.org/stable/frameworks/5.60/kirigami2-5.60.0.tar.xz
+ source = https://download.kde.org/stable/frameworks/5.60/kirigami2-5.60.0.tar.xz.sig
+ validpgpkeys = 53E6B47B45CEA3E0D5B7457758D0EE648A48B3BB
+ sha256sums = f016481d393041513dda11345e9ee84723587fa4be9f17391ed1a5868477e153
+ sha256sums = SKIP
+
+pkgname = android-armv7a-eabi-kirigami2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c19fce7f3fba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# Maintainer: Martchus <martchus@gmx.net>
+# Contributor (maintains regular package): Antonio Rojas <arojas@archlinux.org>
+
+# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
+# you also find the URL of a binary repository.
+
+_pkgname=kirigami2
+_android_arch=armeabi-v7a
+_pkg_arch=armv7a-eabi
+_android_toolchain=arm-linux-androideabi
+_android_platform=21
+_prefix=/opt/android-libs/$_pkg_arch
+
+pkgname=android-$_pkg_arch-$_pkgname
+pkgver=5.60.0
+pkgrel=1
+pkgdesc="A QtQuick based components set (Android, $_pkg_arch)"
+arch=('any')
+url='https://community.kde.org/Frameworks'
+license=(LGPL)
+depends=("android-$_pkg_arch-qt5")
+makedepends=('cmake' 'android-ndk' 'android-sdk' 'extra-cmake-modules')
+conflicts=("android-$_pkgname-$_android_arch")
+replaces=("android-$_pkgname-$_android_arch")
+source=("https://download.kde.org/stable/frameworks/${pkgver%.*}/$_pkgname-$pkgver.tar.xz"{,.sig})
+sha256sums=('f016481d393041513dda11345e9ee84723587fa4be9f17391ed1a5868477e153'
+ 'SKIP')
+validpgpkeys=('53E6B47B45CEA3E0D5B7457758D0EE648A48B3BB') # David Faure <faure@kde.org>
+options=(!buildflags staticlibs !strip !emptydirs)
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+
+ # note: needs workaround for https://gitlab.kitware.com/cmake/cmake/issues/18739 (currently provided outside of the PKGBUILD itself)
+
+ cmake ../$_pkgname-$pkgver \
+ -DCMAKE_SYSTEM_NAME=Android \
+ -DCMAKE_SYSTEM_VERSION=$_android_platform \
+ -DCMAKE_ANDROID_ARCH_ABI=$_android_arch \
+ -DCMAKE_ANDROID_NDK=/opt/android-ndk \
+ -DCMAKE_ANDROID_SDK=/opt/android-sdk \
+ -DCMAKE_ANDROID_STL_TYPE=c++_shared \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX="$_prefix" \
+ -DCMAKE_EXE_LINKER_FLAGS="-Wl,-rpath-link,$_prefix/lib" \
+ -DCMAKE_FIND_ROOT_PATH="/opt/android-ndk/sysroot;$_prefix" \
+ -DECM_DIR=/usr/share/ECM/cmake \
+ -DBUILD_EXAMPLES=OFF \
+ -DBUILD_TESTING=OFF \
+ -DBUILD_QCH=OFF
+ make VERBOSE=1
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+}