summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonzalo Exequiel Pedone2019-07-22 20:28:43 -0300
committerGonzalo Exequiel Pedone2019-07-22 20:28:43 -0300
commit9fa1a894bf16894bf6eb599b47d69166a3f917dd (patch)
treed180fe78c9799f4cd191fcaecfe5ecda69d432bf
downloadaur-9fa1a894bf16894bf6eb599b47d69166a3f917dd.tar.gz
New package.
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD50
-rw-r--r--clang.patch47
4 files changed, 117 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e192dcd36504
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = android-armv7a-eabi-l-smash
+ pkgdesc = MP4 muxer and other tools (android)
+ pkgver = 2.14.5
+ pkgrel = 1
+ url = https://github.com/l-smash/l-smash
+ arch = any
+ license = custom
+ depends = android-ndk
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ options = !emptydirs
+ source = https://github.com/l-smash/l-smash/archive/v2.14.5.tar.gz
+ source = clang.patch
+ sha256sums = e6f7c31de684f4b89ee27e5cd6262bf96f2a5b117ba938d2d606cf6220f05935
+ sha256sums = SKIP
+
+pkgname = android-armv7a-eabi-l-smash
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..78c0d7519d91
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+mingw-w64-d3dcompiler
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..948dd9d30861
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Gonzalo Exequiel Pedone <hipersayan DOT x AT gmail DOT com>
+# Contributor: Karl-Felix Glatzer <karl.glatzer@gmx.de>
+# Contributor: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_android_arch=armv7a-eabi
+
+pkgname=android-${_android_arch}-l-smash
+pkgver=2.14.5
+pkgrel=1
+arch=('any')
+pkgdesc='MP4 muxer and other tools (android)'
+license=('custom')
+url='https://github.com/l-smash/l-smash'
+depends=('android-ndk')
+options=(!strip !buildflags staticlibs !emptydirs)
+source=("https://github.com/l-smash/l-smash/archive/v${pkgver}.tar.gz"
+ "clang.patch")
+sha256sums=('e6f7c31de684f4b89ee27e5cd6262bf96f2a5b117ba938d2d606cf6220f05935'
+ 'SKIP')
+
+prepare() {
+ cd "${srcdir}"/l-smash-${pkgver}
+ patch -Np1 -i ../clang.patch
+}
+
+build() {
+ cd "${srcdir}"/l-smash-${pkgver}
+ source android-env ${_android_arch}
+
+ ./configure \
+ --prefix=${ANDROID_PREFIX} \
+ --cc=${ANDROID_CC} \
+ --cross-prefix=${ANDROID_TOOLS_PREFIX} \
+ --sysroot=${ANDROID_SYSROOT} \
+ --enable-shared \
+ --extra-cflags="$CFLAGS" \
+ --extra-ldflags="$LDFLAGS"
+ make $MAKEFLAGS
+}
+
+package() {
+ cd "${srcdir}"/l-smash-${pkgver}
+ source android-env ${_android_arch}
+
+ make DESTDIR="$pkgdir" install
+ rm -r "${pkgdir}"/${ANDROID_PREFIX_BIN}
+ ${ANDROID_STRIP} -g --strip-unneeded "${pkgdir}"/${ANDROID_PREFIX_LIB}/*.so
+ ${ANDROID_STRIP} -g "$pkgdir"/${ANDROID_PREFIX_LIB}/*.a
+}
diff --git a/clang.patch b/clang.patch
new file mode 100644
index 000000000000..146a174b209c
--- /dev/null
+++ b/clang.patch
@@ -0,0 +1,47 @@
+--- a/configure 2018-02-10 21:08:16.000000000 -0300
++++ b/configure 2019-07-22 19:50:07.745693313 -0300
+@@ -185,9 +185,9 @@
+ test -n "$includedir" || includedir='${prefix}/include'
+
+
+-CC="${CROSS}${CC}"
++CC="${CC}"
+ AR="${CROSS}${AR}"
+-LD="${CROSS}${LD}"
++LD="${LD}"
+ RANLIB="${CROSS}${RANLIB}"
+ STRIP="${CROSS}${STRIP}"
+ for f in "$CC" "$AR" "$LD" "$RANLIB" "$STRIP"; do
+@@ -250,7 +250,7 @@
+ ;;
+ *)
+ SHARED_NAME="liblsmash"
+- SHARED_EXT=".so.$MAJVER"
++ SHARED_EXT=".so"
+ if test -n "$SHAREDLIB"; then
+ CFLAGS="$CFLAGS -fPIC"
+ LDFLAGS="$LDFLAGS -fPIC"
+@@ -290,8 +290,8 @@
+ error_exit "invalid CFLAGS/LDFLAGS"
+ fi
+
+-if cc_check "$CFLAGS -fexcess-precision=fast" "$LDFLAGS"; then
+- CFLAGS="$CFLAGS -fexcess-precision=fast"
++if cc_check "$CFLAGS" "$LDFLAGS"; then
++ CFLAGS="$CFLAGS"
+ fi
+
+ if cc_check "$CFLAGS" "$LDFLAGS -Wl,--large-address-aware"; then
+
+--- a/Makefile 2018-02-10 21:08:16.000000000 -0300
++++ b/Makefile 2019-07-22 20:23:47.377546416 -0300
+@@ -65,9 +65,6 @@
+ endif
+ else
+ install -m 644 $(SHAREDLIB) $(DESTDIR)$(libdir)
+-ifeq ($(SHAREDLIB), liblsmash.so.$(MAJVER))
+- ln -sf $(SHAREDLIB) $(DESTDIR)$(libdir)/liblsmash.so
+-endif
+ endif
+ endif
+